aboutsummaryrefslogtreecommitdiffstats
path: root/audio/openspc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-12 04:10:40 +0800
committertijl <tijl@FreeBSD.org>2014-09-12 04:10:40 +0800
commit0724ab25c1428581389152bd4805563041d6173d (patch)
tree4ef80162f9ab4e7be0b2fe302505a032e8c40024 /audio/openspc
parent3fcfeaf3e41903f6ca708881914879cce0fa62e7 (diff)
downloadfreebsd-ports-gnome-0724ab25c1428581389152bd4805563041d6173d.tar.gz
freebsd-ports-gnome-0724ab25c1428581389152bd4805563041d6173d.tar.zst
freebsd-ports-gnome-0724ab25c1428581389152bd4805563041d6173d.zip
- Convert to USES=libtool and add INSTALL_TARGET=install-strip
- Add USE_AUTOTOOLS=libtoolize (and others) because the bundled libtool is too old to support FreeBSD 4 and higher
Diffstat (limited to 'audio/openspc')
-rw-r--r--audio/openspc/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 7c306a8bfb15..2370419d2c20 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openspc
PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://membres.lycos.fr/pixels/ \
CRITICAL
@@ -13,16 +13,25 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line player for .spc and .zst files
ONLY_FOR_ARCHS= i386 # contains x86 asm code
-USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool
+USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= -a -c -f
USE_GCC= any
+USE_LDCONFIG= yes
PORTDOCS= README
-PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.so \
- lib/libOpenSPC.so.3 lib/libOpenSPC.la lib/libOpenSPC.a
+PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.a \
+ lib/libOpenSPC.so lib/libOpenSPC.so.0 lib/libOpenSPC.so.0.3.1
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} '1,/AUDIOFILE/d' ${WRKSRC}/acinclude.m4
+ @${REINPLACE_CMD} '/AC_PROG_CC/{p;s/.*/AM_PROG_AS/;}' \
+ ${WRKSRC}/configure.in
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}