aboutsummaryrefslogtreecommitdiffstats
path: root/audio/osalp/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-09 02:24:16 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-09 02:24:16 +0800
commitf0ee2b75c525519b5285c6b91a0906684fd94783 (patch)
treec5102f1acef1baae933a4eed37134d4114299952 /audio/osalp/Makefile
parent944160e12845b60fc7e00bbe6502bbf8082aae86 (diff)
downloadfreebsd-ports-gnome-f0ee2b75c525519b5285c6b91a0906684fd94783.tar.gz
freebsd-ports-gnome-f0ee2b75c525519b5285c6b91a0906684fd94783.tar.zst
freebsd-ports-gnome-f0ee2b75c525519b5285c6b91a0906684fd94783.zip
- GNU_CONFIGURE -> USE_LIBTOOL
- Support PREFIX properly bump portrevision PR: 38992 Submitted by: Ports Fury
Diffstat (limited to 'audio/osalp/Makefile')
-rw-r--r--audio/osalp/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/audio/osalp/Makefile b/audio/osalp/Makefile
index 82c89960d0d1..0da6954726ab 100644
--- a/audio/osalp/Makefile
+++ b/audio/osalp/Makefile
@@ -8,19 +8,26 @@
PORTNAME= osalp
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_ARGS= --enable-blade --enable-mpg123 --enable-sox
INSTALLS_SHLIB= yes
+PLIST_SUB= VERSION=${PORTVERSION}
+
+post-patch:
+ @${PERL} -pi -e 's|/usr/local/lib/aflib|${PREFIX}/lib/aflib|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>