aboutsummaryrefslogtreecommitdiffstats
path: root/audio/oss
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2011-07-26 01:45:00 +0800
committerjkim <jkim@FreeBSD.org>2011-07-26 01:45:00 +0800
commit7e8a634ad12a05e9a6ab55cab3615393f954c8c1 (patch)
treebb2786036c625ba2b0e87d92ebc1fcbb2360c8dd /audio/oss
parentc3b32662f241d1e65b9b4259d5dc2df7b6cb3e30 (diff)
downloadfreebsd-ports-gnome-7e8a634ad12a05e9a6ab55cab3615393f954c8c1.tar.gz
freebsd-ports-gnome-7e8a634ad12a05e9a6ab55cab3615393f954c8c1.tar.zst
freebsd-ports-gnome-7e8a634ad12a05e9a6ab55cab3615393f954c8c1.zip
Fix build with Clang.
Diffstat (limited to 'audio/oss')
-rw-r--r--audio/oss/Makefile2
-rw-r--r--audio/oss/files/patch-setup-FreeBSD-build.sh38
2 files changed, 40 insertions, 0 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index 7350f0f0b236..5bd72bf30736 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -63,6 +63,8 @@ IGNORE= requires kernel source to be installed
.include <bsd.port.pre.mk>
+CONFIGURE_ENV+= HOSTCC="${CC}"
+
.if !defined(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
diff --git a/audio/oss/files/patch-setup-FreeBSD-build.sh b/audio/oss/files/patch-setup-FreeBSD-build.sh
new file mode 100644
index 000000000000..40eb0ed30a1b
--- /dev/null
+++ b/audio/oss/files/patch-setup-FreeBSD-build.sh
@@ -0,0 +1,38 @@
+--- setup/FreeBSD/build.sh.orig 2011-01-04 20:33:08.000000000 -0500
++++ setup/FreeBSD/build.sh 2011-07-25 13:39:05.000000000 -0400
+@@ -7,7 +7,7 @@
+ TXT2MAN=$SRCDIR/setup/txt2man
+ else
+ echo "No gawk found. Using lesser replacement" >&2
+- cc -o txt2man origdir/setup/txt2man.c
++ $CC -o txt2man origdir/setup/txt2man.c
+ TXT2MAN=./txt2man
+ fi
+
+@@ -38,7 +38,7 @@
+
+ # Regenerating the config file templates
+ rm -f /tmp/confgen
+-if ! cc -o /tmp/confgen ./setup/FreeBSD/confgen.c
++if ! $CC -o /tmp/confgen ./setup/FreeBSD/confgen.c
+ then
+ echo Building confgen failed
+ exit 1
+@@ -146,7 +146,7 @@
+ # Licensing stuff
+ if test -f $SRCDIR/4front-private/osslic.c
+ then
+- cc -o prototype/usr/sbin/osslic -Isetup -Ikernel/nonfree/include -Ikernel/framework/include -Iinclude -Ikernel/OS/FreeBSD -I$SRCDIR $SRCDIR/4front-private/osslic.c
++ $CC -o prototype/usr/sbin/osslic -Isetup -Ikernel/nonfree/include -Ikernel/framework/include -Iinclude -Ikernel/OS/FreeBSD -I$SRCDIR $SRCDIR/4front-private/osslic.c
+ strip prototype/usr/sbin/osslic
+
+ BITS=3 # Default to 32 bit ELF format
+@@ -162,7 +162,7 @@
+ if test -f 4front-private/ossupdate.c
+ then
+ #ossupdate
+- cc -I. 4front-private/ossupdate.c -s -o prototype/usr/sbin/ossupdate
++ $CC -I. 4front-private/ossupdate.c -s -o prototype/usr/sbin/ossupdate
+ fi
+
+ sh $SRCDIR/setup/build_common.sh $SRCDIR $OSSLIBDIR