aboutsummaryrefslogtreecommitdiffstats
path: root/audio/oss
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-06-05 02:09:14 +0800
committerjkim <jkim@FreeBSD.org>2012-06-05 02:09:14 +0800
commitdb913d4d8d7fcbdb1fae7188bad8242159817e7d (patch)
tree11a1ad813a1348f97bb02ed3b131057bded36a34 /audio/oss
parent1ad5cb94ed525592f5d1bc3a3f1c52033803d7e7 (diff)
downloadfreebsd-ports-gnome-db913d4d8d7fcbdb1fae7188bad8242159817e7d.tar.gz
freebsd-ports-gnome-db913d4d8d7fcbdb1fae7188bad8242159817e7d.tar.zst
freebsd-ports-gnome-db913d4d8d7fcbdb1fae7188bad8242159817e7d.zip
Use the new options framework.
Diffstat (limited to 'audio/oss')
-rw-r--r--audio/oss/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index a1b63bb9634a..76a8b60bf148 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -55,17 +55,18 @@ PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss
-OPTIONS= VORBIS "OGG/Vorbis audio support" on
-
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source to be installed
.endif
-.include <bsd.port.pre.mk>
+CONFIGURE_ENV= HOSTCC="${CC}"
+
+OPTIONS_DEFINE= VORBIS
+OPTIONS_DEFAULT=VORBIS
-CONFIGURE_ENV+= HOSTCC="${CC}"
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
.endif
@@ -124,4 +125,4 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>