aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-Audio
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /audio/p5-Audio
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'audio/p5-Audio')
-rw-r--r--audio/p5-Audio/Makefile2
-rw-r--r--audio/p5-Audio/pkg-plist55
2 files changed, 28 insertions, 29 deletions
diff --git a/audio/p5-Audio/Makefile b/audio/p5-Audio/Makefile
index 336804721cca..29a60851b909 100644
--- a/audio/p5-Audio/Makefile
+++ b/audio/p5-Audio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Audio
PORTVERSION= 1.029
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/audio/p5-Audio/pkg-plist b/audio/p5-Audio/pkg-plist
index 81c6445d0d08..9e1aca32d7af 100644
--- a/audio/p5-Audio/pkg-plist
+++ b/audio/p5-Audio/pkg-plist
@@ -2,33 +2,32 @@ bin/dial
bin/morse
bin/pplay
bin/tkscope
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Audio.h
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Audio.m
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Audio.t
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Audio_f.h
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.0.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.1.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.2.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.3.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.4.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.5.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.6.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.7.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.8.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.9.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.pound.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Data/touchtone.star.au
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Filter.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Play.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Play/freebsd.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Audio/typemap
-%%SITE_PERL%%/%%PERL_ARCH%%/Tk/Scope.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Data/Data.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Data/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Data/solve_polynomial.al
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Play/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Play/freebsd/freebsd.so
+%%SITE_ARCH%%/Audio/Audio.h
+%%SITE_ARCH%%/Audio/Audio.m
+%%SITE_ARCH%%/Audio/Audio.t
+%%SITE_ARCH%%/Audio/Audio_f.h
+%%SITE_ARCH%%/Audio/Data.pm
+%%SITE_ARCH%%/Audio/Data/touchtone.0.au
+%%SITE_ARCH%%/Audio/Data/touchtone.1.au
+%%SITE_ARCH%%/Audio/Data/touchtone.2.au
+%%SITE_ARCH%%/Audio/Data/touchtone.3.au
+%%SITE_ARCH%%/Audio/Data/touchtone.4.au
+%%SITE_ARCH%%/Audio/Data/touchtone.5.au
+%%SITE_ARCH%%/Audio/Data/touchtone.6.au
+%%SITE_ARCH%%/Audio/Data/touchtone.7.au
+%%SITE_ARCH%%/Audio/Data/touchtone.8.au
+%%SITE_ARCH%%/Audio/Data/touchtone.9.au
+%%SITE_ARCH%%/Audio/Data/touchtone.pound.au
+%%SITE_ARCH%%/Audio/Data/touchtone.star.au
+%%SITE_ARCH%%/Audio/Filter.pm
+%%SITE_ARCH%%/Audio/Play.pm
+%%SITE_ARCH%%/Audio/Play/freebsd.pm
+%%SITE_ARCH%%/Audio/typemap
+%%SITE_ARCH%%/Tk/Scope.pm
+%%SITE_ARCH%%/auto/Audio/Data/Data.so
+%%SITE_ARCH%%/auto/Audio/Data/autosplit.ix
+%%SITE_ARCH%%/auto/Audio/Data/solve_polynomial.al
+%%SITE_ARCH%%/auto/Audio/Play/autosplit.ix
+%%SITE_ARCH%%/auto/Audio/Play/freebsd/freebsd.so
%%PERL5_MAN3%%/Audio::Play.3.gz
%%PERL5_MAN3%%/Audio::Data.3.gz