aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-CDDB-File
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-09 09:14:36 +0800
committeredwin <edwin@FreeBSD.org>2003-05-09 09:14:36 +0800
commit43d05575f8ba782e5e6ee2841401677186418eda (patch)
tree54e428c7a70e728833e766ee36fefb5ed7273096 /audio/p5-CDDB-File
parent92a41791b6501fbb72c1704612641d646daafcb9 (diff)
downloadfreebsd-ports-gnome-43d05575f8ba782e5e6ee2841401677186418eda.tar.gz
freebsd-ports-gnome-43d05575f8ba782e5e6ee2841401677186418eda.tar.zst
freebsd-ports-gnome-43d05575f8ba782e5e6ee2841401677186418eda.zip
conditionalize dependencies on modules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. ports/audio only PR: ports/50589 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'audio/p5-CDDB-File')
-rw-r--r--audio/p5-CDDB-File/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/p5-CDDB-File/Makefile b/audio/p5-CDDB-File/Makefile
index b415423f5bed..4649eb0d7066 100644
--- a/audio/p5-CDDB-File/Makefile
+++ b/audio/p5-CDDB-File/Makefile
@@ -16,12 +16,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Parse a CDDB/freedb data file
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= CDDB::File.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>