aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-MP3-Find
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-07-13 04:24:34 +0800
committernovel <novel@FreeBSD.org>2006-07-13 04:24:34 +0800
commit349fba33fc6657f596b6b96ef225a905f93b8e12 (patch)
treeccdac674f281867284645ce65f2253eaa4d32278 /audio/p5-MP3-Find
parent55d9390c6578ef98c970f0d7c537a7fd57c3e747 (diff)
downloadfreebsd-ports-gnome-349fba33fc6657f596b6b96ef225a905f93b8e12.tar.gz
freebsd-ports-gnome-349fba33fc6657f596b6b96ef225a905f93b8e12.tar.zst
freebsd-ports-gnome-349fba33fc6657f596b6b96ef225a905f93b8e12.zip
This module allows you to search for MP3 files by their ID3 tags.
You can ask for the results to be sorted by one or more of those tags, and return either the list of filenames (the deault), a printf-style formatted string for each file using its ID3 tags, or the actual Perl data structure representing the results. WWW: http://search.cpan.org/dist/MP3-Find/ PR: ports/100149 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'audio/p5-MP3-Find')
-rw-r--r--audio/p5-MP3-Find/Makefile29
-rw-r--r--audio/p5-MP3-Find/distinfo3
-rw-r--r--audio/p5-MP3-Find/pkg-descr7
-rw-r--r--audio/p5-MP3-Find/pkg-plist13
4 files changed, 52 insertions, 0 deletions
diff --git a/audio/p5-MP3-Find/Makefile b/audio/p5-MP3-Find/Makefile
new file mode 100644
index 000000000000..66af084c5994
--- /dev/null
+++ b/audio/p5-MP3-Find/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-MP3-Find
+# Date created: 2006-07-12
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MP3-Find
+PORTVERSION= 0.06
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= ../../authors/id/P/PE/PEICHMAN
+MASTER_SITE_SUBDIR= MP3
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Search and sort MP3 files based on their ID3 tags
+
+BUILD_DEPENDS= ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN1= mp3db.1 mp3find.1
+MAN3= MP3::Find::DB.3 MP3::Find::Filesystem.3 MP3::Find.3 MP3::Find::Base.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/audio/p5-MP3-Find/distinfo b/audio/p5-MP3-Find/distinfo
new file mode 100644
index 000000000000..25c8acae91bf
--- /dev/null
+++ b/audio/p5-MP3-Find/distinfo
@@ -0,0 +1,3 @@
+MD5 (MP3-Find-0.06.tar.gz) = 6de91612713767e1470db6f91ab35c17
+SHA256 (MP3-Find-0.06.tar.gz) = e833a6526ac88c3ea4cbbe001025237c2977bd76fdf07be1b7b3907f61d39501
+SIZE (MP3-Find-0.06.tar.gz) = 29645
diff --git a/audio/p5-MP3-Find/pkg-descr b/audio/p5-MP3-Find/pkg-descr
new file mode 100644
index 000000000000..3d084458c1b3
--- /dev/null
+++ b/audio/p5-MP3-Find/pkg-descr
@@ -0,0 +1,7 @@
+This module allows you to search for MP3 files by their ID3 tags.
+You can ask for the results to be sorted by one or more of those tags,
+and return either the list of filenames (the deault), a printf-style
+formatted string for each file using its ID3 tags, or the actual Perl
+data structure representing the results.
+
+WWW: http://search.cpan.org/dist/MP3-Find/
diff --git a/audio/p5-MP3-Find/pkg-plist b/audio/p5-MP3-Find/pkg-plist
new file mode 100644
index 000000000000..c912165a3515
--- /dev/null
+++ b/audio/p5-MP3-Find/pkg-plist
@@ -0,0 +1,13 @@
+bin/mp3db
+bin/mp3find
+%%SITE_PERL%%/MP3/Find.pm
+%%SITE_PERL%%/MP3/Find/Base.pm
+%%SITE_PERL%%/MP3/Find/DB.pm
+%%SITE_PERL%%/MP3/Find/Filesystem.pm
+%%SITE_PERL%%/MP3/Find/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MP3/Find/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MP3/Find
+@dirrm %%SITE_PERL%%/MP3/Find
+@dirrm %%SITE_PERL%%/MP3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MP3
+@dirrmtry %%SITE_PERL%%/MP3