aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-Xmms/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-19 17:41:17 +0800
committerwill <will@FreeBSD.org>2000-12-19 17:41:17 +0800
commitea4a74061481411ac96fc9d7d3dec873c4819fc0 (patch)
tree09db495b00b6d0cd9428ef816d9fbfc893c02db9 /audio/p5-Xmms/Makefile
parent0b00872b87147eb8752689cc0cbb832b44b9e089 (diff)
downloadfreebsd-ports-gnome-ea4a74061481411ac96fc9d7d3dec873c4819fc0.tar.gz
freebsd-ports-gnome-ea4a74061481411ac96fc9d7d3dec873c4819fc0.tar.zst
freebsd-ports-gnome-ea4a74061481411ac96fc9d7d3dec873c4819fc0.zip
Add p5-Xmms 0.10, a perl module that provides a "remote shell" for xmms.
PR: 23467 Submitted by: Jeremy Shaffner <jeremy@external.org>
Diffstat (limited to 'audio/p5-Xmms/Makefile')
-rw-r--r--audio/p5-Xmms/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/p5-Xmms/Makefile b/audio/p5-Xmms/Makefile
new file mode 100644
index 000000000000..581517d6f32b
--- /dev/null
+++ b/audio/p5-Xmms/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Xmms
+# Date created: 10 December 2000
+# Whom: Jeremy Shaffner <jeremy@external.org>
+#
+# $FreeBSD$
+
+PORTNAME= Xmms
+PORTVERSION= 0.10
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Xmms
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-Perl-${PORTVERSION}
+
+MAINTAINER= jeremy@external.org
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/audio/xmms \
+ ${site_perl}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${site_perl}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${site_perl}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+
+site_perl= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+USE_PERL5= YES
+
+MAN3= Xmms::Remote.3 \
+ Xmms::SongChange.3 \
+ Xmms.3 \
+ Bundle::Xmms.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>