aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-Xmms
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-08-23 03:05:37 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-08-23 03:05:37 +0800
commitc9b8320a0dbd3f6b680d896f5b13e5a07591cf72 (patch)
tree546cde4a710ad394762c79409ba55870f3488904 /audio/p5-Xmms
parentd165dc1fec3f15d76b2550c2149f69ed49c40945 (diff)
downloadfreebsd-ports-gnome-c9b8320a0dbd3f6b680d896f5b13e5a07591cf72.tar.gz
freebsd-ports-gnome-c9b8320a0dbd3f6b680d896f5b13e5a07591cf72.tar.zst
freebsd-ports-gnome-c9b8320a0dbd3f6b680d896f5b13e5a07591cf72.zip
- Use SITE_PERL directly
- Remove outdated PERL_LEVEL check - Replace MPEG::MP3Info with MP3::Info since newer p5-MP3-Info no longer provides MPEG::MP3Info
Diffstat (limited to 'audio/p5-Xmms')
-rw-r--r--audio/p5-Xmms/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/audio/p5-Xmms/Makefile b/audio/p5-Xmms/Makefile
index a35a7107c7f3..d211cc96f767 100644
--- a/audio/p5-Xmms/Makefile
+++ b/audio/p5-Xmms/Makefile
@@ -16,26 +16,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive remote control shell for xmms
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms \
- ${site_perl}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
- ${site_perl}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+ p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info \
+ p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
-site_perl= ${SITE_PERL}
+PERL_CONFIGURE= yes
+REINPLACE_ARGS= -i ''
-PERL_CONFIGURE= YES
-
-MAN3= Xmms::Remote.3 \
- Xmms::SongChange.3 \
+MAN3= Bundle::Xmms.3 \
Xmms.3 \
- Bundle::Xmms.3
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500800
-MAN3+= Xmms::Config.3
-.endif
+ Xmms::Config.3 \
+ Xmms::Remote.3 \
+ Xmms::SongChange.3
post-patch:
+ @${REINPLACE_CMD} -e 's|MPEG::MP3Info|MP3::Info|g' \
+ ${WRKSRC}/Makefile.PL ${WRKSRC}/Remote/Remote.pm \
+ ${WRKSRC}/lib/Bundle/Xmms.pm ${WRKSRC}/lib/Xmms.pm
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/SongChange/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>