aboutsummaryrefslogtreecommitdiffstats
path: root/audio/padevchooser
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /audio/padevchooser
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'audio/padevchooser')
-rw-r--r--audio/padevchooser/Makefile4
-rw-r--r--audio/padevchooser/files/patch-src_padevchooser.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/audio/padevchooser/Makefile b/audio/padevchooser/Makefile
index 1cd295f67b91..1781c1eca8ed 100644
--- a/audio/padevchooser/Makefile
+++ b/audio/padevchooser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= padevchooser
PORTVERSION= 0.9.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
@@ -16,7 +16,7 @@ COMMENT= GTK icon tray for PulseAudio
LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
pulse.0:${PORTSDIR}/audio/pulseaudio \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
avahi-core:${PORTSDIR}/net/avahi
RUN_DEPENDES= dbus-daemon:${PORTSDIR}/devel/dbus
diff --git a/audio/padevchooser/files/patch-src_padevchooser.c b/audio/padevchooser/files/patch-src_padevchooser.c
new file mode 100644
index 000000000000..c2f3046e8f69
--- /dev/null
+++ b/audio/padevchooser/files/patch-src_padevchooser.c
@@ -0,0 +1,11 @@
+--- src/padevchooser.c.orig 2011-08-11 21:41:17.000000000 +0200
++++ src/padevchooser.c 2011-08-11 21:41:42.000000000 +0200
+@@ -162,7 +162,7 @@ static void notify_event(const char *tit
+
+ if (!notification) {
+ s = g_strdup_printf("<i>%s</i>\n%s", title, text);
+- notification = notify_notification_new(title, s, "audio-card", GTK_WIDGET(tray_icon));
++ notification = notify_notification_new(title, s, "audio-card");
+ notify_notification_set_category(notification, "device.added");
+ notify_notification_set_urgency(notification, NOTIFY_URGENCY_LOW);
+ g_signal_connect_swapped(G_OBJECT(notification), "closed", G_CALLBACK(notification_closed), NULL);