aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pd/Makefile
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-09-23 18:07:35 +0800
committergahr <gahr@FreeBSD.org>2013-09-23 18:07:35 +0800
commit5304a0986a69d3c69207976a4a474ac6efd29718 (patch)
tree17f63da65890c10be66dba80f8fb39f99d1a85e1 /audio/pd/Makefile
parent93409162a859a58177f59c35353ccf10a0cea26b (diff)
downloadfreebsd-ports-gnome-5304a0986a69d3c69207976a4a474ac6efd29718.tar.gz
freebsd-ports-gnome-5304a0986a69d3c69207976a4a474ac6efd29718.tar.zst
freebsd-ports-gnome-5304a0986a69d3c69207976a4a474ac6efd29718.zip
- Convert to USES+=tcl
- Convert to new LIB_DEPENDS format - Use PORTDOCS=* instead of listing them in pkg-plist
Diffstat (limited to 'audio/pd/Makefile')
-rw-r--r--audio/pd/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index 31da68440c0b..676e6f2c9caa 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -21,15 +21,15 @@ OPTIONS_DEFAULT=FFTW
WRKSRC= ${WRKDIR}/${DISTNAME:S,${DISTVERSIONSUFFIX},,}
-USES= gettext gmake pkgconfig
+USES= gettext gmake pkgconfig tk:wrapper
NO_STAGE= yes
-USE_TK_WRAPPER= yes
USE_AUTOTOOLS= aclocal libtoolize autoconf automake
ACLOCAL_ARGS= -I m4/generated -I m4
LIBTOOLIZE_ARGS=--install --force
AUTOMAKE_ARGS= --add-missing --copy --force-missing
MAN1= pd.1 pdreceive.1 pdsend.1
+PORTDOCS= *
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -37,7 +37,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
CONFIGURE_ARGS+= --enable-alsa
.else
CONFIGURE_ARGS+= --disable-alsa
@@ -45,14 +45,14 @@ CONFIGURE_ARGS+= --disable-alsa
.if ${PORT_OPTIONS:MFFTW}
BUILD_DEPENDS+= fftw3>0:${PORTSDIR}/math/fftw3
-LIB_DEPENDS+= fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= libfftw3f.so:${PORTSDIR}/math/fftw3-float
CONFIGURE_ARGS+= --enable-fftw
.else
CONFIGURE_ARGS+= --disable-fftw
.endif
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+= --enable-jack
.else
CONFIGURE_ARGS+= --disable-jack