aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pd
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-14 23:08:08 +0800
committerpi <pi@FreeBSD.org>2016-05-14 23:08:08 +0800
commit81a3fc9bfb2fe9ceefa6a57d87444e7d4e38e0df (patch)
tree12d3c5695b4421ff0d81b891c15bcdc28f668892 /audio/pd
parent50b99d51f65d6bab1ce457a49a7b41c97bb9427d (diff)
downloadfreebsd-ports-gnome-81a3fc9bfb2fe9ceefa6a57d87444e7d4e38e0df.tar.gz
freebsd-ports-gnome-81a3fc9bfb2fe9ceefa6a57d87444e7d4e38e0df.tar.zst
freebsd-ports-gnome-81a3fc9bfb2fe9ceefa6a57d87444e7d4e38e0df.zip
audio/pd: Fix builtin documentation
- also pet portlint PR: 209493 Submitted by: Tobias Brodel <brittlehaus@gmail.com> (maintainer)
Diffstat (limited to 'audio/pd')
-rw-r--r--audio/pd/Makefile7
-rw-r--r--audio/pd/files/patch-extra_pd_pd.c6
-rw-r--r--audio/pd/files/patch-src_s__main.c14
3 files changed, 7 insertions, 20 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index d9956b226725..c8f2ac5efc8d 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -4,6 +4,7 @@
PORTNAME= pd
DISTVERSION= 0.47-0
DISTVERSIONSUFFIX= .src
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://msp.ucsd.edu/Software/
@@ -23,7 +24,6 @@ USES= autoreconf gettext gmake libtool pkgconfig shebangfix \
tcl:wrapper tk:wrapper
SHEBANG_FILES= tcl/pkg_mkIndex.tcl
SHEBANG_LANG= tclsh
-tclsh_OLD_CMD= /usr/bin/tclsh
tclsh_CMD= ${LOCALBASE}/bin/tclsh
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_pthread_pthread_create=no
@@ -43,8 +43,9 @@ JACK_LIB_DEPENDS= libjack.so:audio/jack
post-patch:
${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|__FreeBSD_kernel__|__FreeBSD__|g ; \
- s|__x86_64__|__amd64__|g ; \
- s|<alloca\.h>|<stdlib.h>|g'
+ s|__x86_64__|__amd64__|g'
+ ${FIND} ${WRKSRC}/extra -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<alloca\.h>|<stdlib.h>|g'
${REINPLACE_CMD} -e \
's|\*kfreebsd\*gnu\*)|*freebsd*)| ; \
s|portaudio=yes|portaudio=no| ; \
diff --git a/audio/pd/files/patch-extra_pd_pd.c b/audio/pd/files/patch-extra_pd_pd.c
index cd900d12cd21..a8c0e0ce9e7e 100644
--- a/audio/pd/files/patch-extra_pd_pd.c
+++ b/audio/pd/files/patch-extra_pd_pd.c
@@ -1,6 +1,6 @@
---- extra/pd~/pd~.c.orig 2010-07-29 05:55:17.000000000 +0900
-+++ extra/pd~/pd~.c 2011-04-06 19:18:20.000000000 +0900
-@@ -19,6 +19,7 @@
+--- extra/pd~/pd~.c.orig 2016-05-13 08:31:10 UTC
++++ extra/pd~/pd~.c
+@@ -19,6 +19,7 @@ typedef int socklen_t;
#include <stdlib.h>
#include <errno.h>
#include <ctype.h>
diff --git a/audio/pd/files/patch-src_s__main.c b/audio/pd/files/patch-src_s__main.c
deleted file mode 100644
index 39f08ba89dd0..000000000000
--- a/audio/pd/files/patch-src_s__main.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/s_main.c.orig 2015-09-09 23:08:21 UTC
-+++ src/s_main.c
-@@ -1137,7 +1137,11 @@ static void sys_afterargparse(void)
- /* add "doc/5.reference" library to helppath */
- strncpy(sbuf, sys_libdir->s_name, MAXPDSTRING-30);
- sbuf[MAXPDSTRING-30] = 0;
-+#if defined(__FreeBSD__)
-+ strcat(sbuf, "/share/doc/pd/5.reference");
-+#else
- strcat(sbuf, "/doc/5.reference");
-+#endif
- sys_helppath = namelist_append_files(sys_helppath, sbuf);
- /* correct to make audio and MIDI device lists zero based. On
- MMIO, however, "1" really means the second device (the first one