aboutsummaryrefslogtreecommitdiffstats
path: root/audio/picard/files
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-04-08 02:18:07 +0800
committerlioux <lioux@FreeBSD.org>2006-04-08 02:18:07 +0800
commitf89f6a9b06bbf3039ae30b3c9d82e30ad6b69b1c (patch)
tree61f86d73cc273b9852d56a1b7162e54474114ff1 /audio/picard/files
parent8893686c400a1bde40a42e9a408cad0de1cf3ff3 (diff)
downloadfreebsd-ports-gnome-f89f6a9b06bbf3039ae30b3c9d82e30ad6b69b1c.tar.gz
freebsd-ports-gnome-f89f6a9b06bbf3039ae30b3c9d82e30ad6b69b1c.tar.zst
freebsd-ports-gnome-f89f6a9b06bbf3039ae30b3c9d82e30ad6b69b1c.zip
New port picard version 0.6.0: Next generation MusicBrainzTagger
Diffstat (limited to 'audio/picard/files')
-rw-r--r--audio/picard/files/__init__.py37
-rw-r--r--audio/picard/files/extra-psyco-patch-tagger.py16
-rw-r--r--audio/picard/files/setup.py40
3 files changed, 93 insertions, 0 deletions
diff --git a/audio/picard/files/__init__.py b/audio/picard/files/__init__.py
new file mode 100644
index 000000000000..2f8f644f2894
--- /dev/null
+++ b/audio/picard/files/__init__.py
@@ -0,0 +1,37 @@
+""" picard modules for Python
+
+Copyright (c) 2005 Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
+
+ $Id$
+
+"""
+# (note that subpackages have their own version number)
+__version__ = '%%VERSION%%'
+
+# Copyright notice string
+__copyright__ = """\
+ See the documentation for information on copyrights,
+ or contact the author. All Rights Reserved.
+"""
diff --git a/audio/picard/files/extra-psyco-patch-tagger.py b/audio/picard/files/extra-psyco-patch-tagger.py
new file mode 100644
index 000000000000..9e8324e37fab
--- /dev/null
+++ b/audio/picard/files/extra-psyco-patch-tagger.py
@@ -0,0 +1,16 @@
+--- tagger.py.orig Thu Apr 6 16:48:21 2006
++++ tagger.py Thu Apr 6 16:48:47 2006
+@@ -54,6 +54,13 @@
+ # ***** END LICENSE BLOCK *****
+
+ try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
++
++try:
+ import wxversion
+ wxversion.select(["2.6-unicode"])
+ except:
diff --git a/audio/picard/files/setup.py b/audio/picard/files/setup.py
new file mode 100644
index 000000000000..7dba8e77d33a
--- /dev/null
+++ b/audio/picard/files/setup.py
@@ -0,0 +1,40 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2005 Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+# $Id$
+
+from distutils.core import setup
+
+import glob
+
+scripts = ["MBTagger", "mb_tagger.py"]
+
+setup(
+ name = "Picard",
+ url = "http://wiki.musicbrainz.org/PicardTagger",
+ scripts = scripts,
+ packages = ["picard", "picard/browser", "picard/lib", "picard/ui", "picard/ui/options"],
+ )