aboutsummaryrefslogtreecommitdiffstats
path: root/audio/prokyon3/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-06-14 15:02:45 +0800
committervs <vs@FreeBSD.org>2007-06-14 15:02:45 +0800
commit06bbc86455a8986c5fa80bb24dbc7e90451234b5 (patch)
tree5e6830a6564bacab27606ef8debf27df27721a29 /audio/prokyon3/Makefile
parent9f77d302c225e18f362a6ee45b4b26e3e7528315 (diff)
downloadfreebsd-ports-gnome-06bbc86455a8986c5fa80bb24dbc7e90451234b5.tar.gz
freebsd-ports-gnome-06bbc86455a8986c5fa80bb24dbc7e90451234b5.tar.zst
freebsd-ports-gnome-06bbc86455a8986c5fa80bb24dbc7e90451234b5.zip
Unbreak by setting and using LDFLAGS correctly to pick up gettext.
Add WWW:-tag while here.
Diffstat (limited to 'audio/prokyon3/Makefile')
-rw-r--r--audio/prokyon3/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/prokyon3/Makefile b/audio/prokyon3/Makefile
index c5a05b8efc9f..9d83d936d4a0 100644
--- a/audio/prokyon3/Makefile
+++ b/audio/prokyon3/Makefile
@@ -20,19 +20,19 @@ LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib \
vorbis.3:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-BROKEN= Does not compile
-
USE_QT_VER= 3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
+USE_GETTEXT= yes
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
--with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
QT_NONSTANDARD= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include \
- -I${QT_PREFIX}/include"
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include \
+ -I${QT_PREFIX}/include" LDFLAGS="${LDFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_BURN)
USE_CDRTOOLS= yes