aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pulseaudio/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2009-09-07 05:18:50 +0800
committerflz <flz@FreeBSD.org>2009-09-07 05:18:50 +0800
commitaee1abb61b78c082c5d83f9b84996a4e129322b3 (patch)
tree72655187281a51d755f8177c7c85e0ad80cec664 /audio/pulseaudio/Makefile
parent97fa68f3fea860d6efa872e0a7eb28125abed8a2 (diff)
downloadfreebsd-ports-gnome-aee1abb61b78c082c5d83f9b84996a4e129322b3.tar.gz
freebsd-ports-gnome-aee1abb61b78c082c5d83f9b84996a4e129322b3.tar.zst
freebsd-ports-gnome-aee1abb61b78c082c5d83f9b84996a4e129322b3.zip
Add support to create users and groups from information stored in UIDs/GIDs
files. Users and groups won't be deleted at deinstall time as we're lacking a refcount to know if any port is using them. Also convert a few ports while I'm here. PR: ports/108514 Submitted by: mm, self
Diffstat (limited to 'audio/pulseaudio/Makefile')
-rw-r--r--audio/pulseaudio/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index aa0fa5bb9911..3889fa8fcb46 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pulseaudio
PORTVERSION= 0.9.15
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
@@ -41,6 +41,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --localstatedir=/var \
--disable-lirc # untested
+USERS= pulse
+GROUPS= pulse pulse-access pulse-rt
+
OPTIONS= JACK "JACK audio support" Off \
AVAHI "Enable Avahi mDNS support" On \
HAL "Enable HAL support" On \
@@ -114,9 +117,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/${ii} \
${PREFIX}/etc/pulse/${ii}-dist
.endfor
-.if !defined(PACKAGE_BUILDING)
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>