aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pulseaudio/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-11-03 20:25:26 +0800
committerkwm <kwm@FreeBSD.org>2011-11-03 20:25:26 +0800
commitcb88dd857113ae5e6b9bd3d93b258701cb384422 (patch)
treef19b5bdbe5512de46fb7086794704212a393301e /audio/pulseaudio/Makefile
parent3766b4bf2da1c7c3a27b3b5a336c182d5adffde8 (diff)
downloadfreebsd-ports-gnome-cb88dd857113ae5e6b9bd3d93b258701cb384422.tar.gz
freebsd-ports-gnome-cb88dd857113ae5e6b9bd3d93b258701cb384422.tar.zst
freebsd-ports-gnome-cb88dd857113ae5e6b9bd3d93b258701cb384422.zip
Update MASTER_SITE
Don't pickup linux/input.h, this should fix plist failure because the evdev modules is build (which is useless for us). [2] Disable alsa support.. Remove FreeBSD 6.x patch. Disable mmap support on FreeBSD versions that don't have support for it. [1] PR: ports/161567 [2] Submitted by: avg@ [1] Reported by: Takefu <takefu@airport.fm> [2]
Diffstat (limited to 'audio/pulseaudio/Makefile')
-rw-r--r--audio/pulseaudio/Makefile33
1 files changed, 13 insertions, 20 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 8057703cedb0..74e67ca2a8c1 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -12,9 +12,9 @@
PORTNAME= pulseaudio
PORTVERSION= 0.9.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
-MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
+MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Sound server for UNIX
@@ -38,12 +38,17 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
OPENSSL_CFLAGS="-I/usr/include" \
OPENSSL_LIBS="-lcrypto -lssl" \
- LIBS="-lm -lintl"
+ LIBS="-lm -lintl" \
+ ac_cv_header_linux_input_h=
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=/var \
--with-database=gdbm \
+ --without-caps \
+ --disable-alsa \
+ --disable-udev \
+ --disable-gtk2 \
--disable-lirc # untested
USERS= pulse
@@ -63,19 +68,6 @@ MAN5= default.pa.5 pulse-client.conf.5 pulse-daemon.conf.5
.include <bsd.port.pre.mk>
-#.if ${ARCH} == "sparc64"
-#BROKEN= Does not compile on sparc64
-#.endif
-
-.if ( ${OSVERSION} > 800000 && ${OSVERSION} < 800080 ) || \
- ${OSVERSION} < 702000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_daemon_main.c \
- ${FILESDIR}/extra-patch-src_daemon_start-pulseaudio-x11.in \
- ${FILESDIR}/extra-patch-src_pulse_context.c
-.endif
-
-CONFIGURE_ARGS+= --without-caps
-
.if defined(WITH_JACK)
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
PLIST_SUB+= JACK=""
@@ -108,13 +100,14 @@ CONFIGURE_ARGS+=--disable-gconf
PLIST_SUB+= GCONF="@comment "
.endif
+.if ((${OSVERSION} >= 800000) && (${OSVERSION} < 802504)) || \
+ ((${OSVERSION} >= 900000) && (${OSVERSION} < 900037))
+EXTRA_PATCHES+= ${FILESDIR}/extra-src_modules_oss_module-oss.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/daemon/default.pa.in
-.if ${OSVERSION} < 700042
- @${REINPLACE_CMD} -e 's|-Wl,-no-undefined||' \
- ${WRKSRC}/src/Makefile.in
-.endif
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure