aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pulseaudio/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-05-21 00:22:20 +0800
committermezz <mezz@FreeBSD.org>2012-05-21 00:22:20 +0800
commitf9fca80acf1bb54e3d4d8c2222d5ff6679767b76 (patch)
treed3967c6249240b03c313f4fe520b6be81f9b6fea /audio/pulseaudio/Makefile
parent9b984a881e4702ca92550644320a7b510ae9944f (diff)
downloadfreebsd-ports-gnome-f9fca80acf1bb54e3d4d8c2222d5ff6679767b76.tar.gz
freebsd-ports-gnome-f9fca80acf1bb54e3d4d8c2222d5ff6679767b76.tar.zst
freebsd-ports-gnome-f9fca80acf1bb54e3d4d8c2222d5ff6679767b76.zip
Fix the build with clang.
PR: ports/167957 Submitted by: Alan Hicks <ahicks@p-o.co.uk>
Diffstat (limited to 'audio/pulseaudio/Makefile')
-rw-r--r--audio/pulseaudio/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 5e710e8b1c3b..6de0e2da012d 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -42,6 +42,10 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.if ${CC} == clang
+CFLAGS+= -fheinous-gnu-extensions
+.endif
+
CONFIGURE_ARGS= --localstatedir=/var \
--with-database=gdbm \
--without-caps \