aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rawrec
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-08 18:22:14 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-08 18:22:14 +0800
commit7061c825a5210c03732b321ec79be5b806d45809 (patch)
tree0b8baf7e1afe46bdc06d53d1075241021e654302 /audio/rawrec
parentcde117293fcf37aa19d9f54acecb0887be0a0d25 (diff)
downloadfreebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.tar.gz
freebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.tar.zst
freebsd-ports-gnome-7061c825a5210c03732b321ec79be5b806d45809.zip
PERL -> REINPLACE_CMD
PR: 39283 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'audio/rawrec')
-rw-r--r--audio/rawrec/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/rawrec/Makefile b/audio/rawrec/Makefile
index 5875d3a872ed..2c2da8cdf6e7 100644
--- a/audio/rawrec/Makefile
+++ b/audio/rawrec/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
@@ -30,7 +31,7 @@ MAN1= rawrec.1
MLINKS= rawrec.1 rawplay.1
post-patch:
- @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<linux/soundcard.h>|<sys/soundcard.h>|g'
do-install: