aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-06-14 12:49:35 +0800
committermarcus <marcus@FreeBSD.org>2006-06-14 12:49:35 +0800
commit2fdcf43eeec5f27d40ddca4d4d4316cbb61c5d6d (patch)
treee00b1037f2ce8af976b39aae2b8b476a289bd9fb /audio/rhythmbox
parentbc570bc393b9c85e1a220e1f443d637fb77ea4e5 (diff)
downloadfreebsd-ports-gnome-2fdcf43eeec5f27d40ddca4d4d4316cbb61c5d6d.tar.gz
freebsd-ports-gnome-2fdcf43eeec5f27d40ddca4d4d4316cbb61c5d6d.tar.zst
freebsd-ports-gnome-2fdcf43eeec5f27d40ddca4d4d4316cbb61c5d6d.zip
Chase the libnotify update.
Submitted by: Chen, Lihong <lihong.chen@gmail.com>
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/rhythmbox/files/patch-widges_eggtrayicon.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index d09e3da3cf93..67ee1821bfaa 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.9.4.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
diff --git a/audio/rhythmbox/files/patch-widges_eggtrayicon.c b/audio/rhythmbox/files/patch-widges_eggtrayicon.c
new file mode 100644
index 000000000000..bb9d982e2878
--- /dev/null
+++ b/audio/rhythmbox/files/patch-widges_eggtrayicon.c
@@ -0,0 +1,11 @@
+--- widgets/eggtrayicon.c.orig Wed Jun 14 12:25:10 2006
++++ widgets/eggtrayicon.c Wed Jun 14 12:26:41 2006
+@@ -571,7 +571,7 @@
+
+ if (pixbuf)
+ {
+-#if (LIBNOTIFY_VERSION_MICRO < 2)
++#if ((LIBNOTIFY_VERSION_MINOR <= 3) && (LIBNOTIFY_VERSION_MICRO < 2))
+ notify_notification_set_icon_data_from_pixbuf (icon->notify->handle, pixbuf);
+ #else
+ notify_notification_set_icon_from_pixbuf (icon->notify->handle, pixbuf);