aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rio500
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2006-01-17 21:13:02 +0800
committerarved <arved@FreeBSD.org>2006-01-17 21:13:02 +0800
commit1cadb20be071bc0269e9566479b122db0fc015a1 (patch)
tree9495c6c100e7006db0dad183c171fa96cca05726 /audio/rio500
parent57d6270f2845cbf8d7f2a7ae586b77d7e7f698d6 (diff)
downloadfreebsd-ports-gnome-1cadb20be071bc0269e9566479b122db0fc015a1.tar.gz
freebsd-ports-gnome-1cadb20be071bc0269e9566479b122db0fc015a1.tar.zst
freebsd-ports-gnome-1cadb20be071bc0269e9566479b122db0fc015a1.zip
Unbreak on sparc64 (and other big endian archs)
Diffstat (limited to 'audio/rio500')
-rw-r--r--audio/rio500/Makefile9
-rw-r--r--audio/rio500/files/patch-include-libfon.h12
2 files changed, 18 insertions, 3 deletions
diff --git a/audio/rio500/Makefile b/audio/rio500/Makefile
index 55d077de6d7f..bbe15ce5a997 100644
--- a/audio/rio500/Makefile
+++ b/audio/rio500/Makefile
@@ -20,10 +20,13 @@ CONFIGURE_ARGS= --with-devicepath='/dev' \
--with-deviceentry='urio0' \
--with-id3support
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,byteswap.h,sys/endian.h," \
+ ${WRKSRC}/lib/libfon.c \
+ ${WRKSRC}/lib/librio500.c
.include <bsd.port.post.mk>
diff --git a/audio/rio500/files/patch-include-libfon.h b/audio/rio500/files/patch-include-libfon.h
new file mode 100644
index 000000000000..174de6261ce3
--- /dev/null
+++ b/audio/rio500/files/patch-include-libfon.h
@@ -0,0 +1,12 @@
+--- include/libfon.h.orig Tue Jan 17 14:07:33 2006
++++ include/libfon.h Tue Jan 17 14:08:42 2006
+@@ -34,6 +34,9 @@
+ #define MZ_HEADER_MAGIC 0x5a4d
+ #define NE_HEADER_MAGIC 0x454e
+
++#define bswap_16(x) (be16toh(x))
++#define bswap_32(x) (be32toh(x))
++
+ typedef struct {
+ uint16_t magic;
+ uint16_t dummy[29]; /* MZ Header data that we want to skip */