aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rio
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>2003-04-02 10:46:39 +0800
committerimp <imp@FreeBSD.org>2003-04-02 10:46:39 +0800
commit2bedd57212608377a31b2ffc7b279ea24cc9ee09 (patch)
tree3f0e2b569b64fa060b70f925c4e99452b801f9d1 /audio/rio
parent9bbd062b63d55bce490cc12678693955d4d1b372 (diff)
downloadfreebsd-ports-gnome-2bedd57212608377a31b2ffc7b279ea24cc9ee09.tar.gz
freebsd-ports-gnome-2bedd57212608377a31b2ffc7b279ea24cc9ee09.tar.zst
freebsd-ports-gnome-2bedd57212608377a31b2ffc7b279ea24cc9ee09.zip
Fix building on -current. Kludge around the ffs issue and use time_t
where a time_t is ment, not a long.
Diffstat (limited to 'audio/rio')
-rw-r--r--audio/rio/Makefile4
-rw-r--r--audio/rio/files/patch-ab4
-rw-r--r--audio/rio/files/patch-ad20
3 files changed, 23 insertions, 5 deletions
diff --git a/audio/rio/Makefile b/audio/rio/Makefile
index df767e16eec1..bd3fa51cc6bb 100644
--- a/audio/rio/Makefile
+++ b/audio/rio/Makefile
@@ -23,10 +23,6 @@ BINMODE= 4755
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rio ${PREFIX}/bin
diff --git a/audio/rio/files/patch-ab b/audio/rio/files/patch-ab
index b4515d6791f6..9947818f6127 100644
--- a/audio/rio/files/patch-ab
+++ b/audio/rio/files/patch-ab
@@ -2,7 +2,7 @@
--- rio.cpp Fri Feb 18 11:02:11 2000
***************
*** 53,58 ****
---- 53,76 ----
+--- 53,78 ----
#define CLOCK_SECOND 1000
#define DELETEARRAY delete[]
@@ -11,7 +11,9 @@
+ // (anybody know if this stuff applies more generally to other BSDs?)
+ #include <fcntl.h>
+ #include <unistd.h>
++ #define ffs _ffs_hack
+ #include <machine/cpufunc.h>
++ #undef ffs
+ #if defined(__alpha__)
+ #include <sys/types.h>
+ extern "C" {
diff --git a/audio/rio/files/patch-ad b/audio/rio/files/patch-ad
new file mode 100644
index 000000000000..dc64fda1172d
--- /dev/null
+++ b/audio/rio/files/patch-ad
@@ -0,0 +1,20 @@
+--- app.cpp.orig Tue Apr 1 19:32:47 2003
++++ app.cpp Fri Jun 11 10:26:46 1999
+@@ -46,7 +46,7 @@
+ #elif defined(__FreeBSD__)
+ // FreeBSD g++
+ #include <unistd.h>
+- #include <sys/syslimits.h>
++ #include <limits.h>
+ #define SIZE_MAXPATH PATH_MAX
+ #define DELETEARRAY delete[]
+
+@@ -97,7 +97,7 @@
+
+ ///////////////////////////////////////////////////////////////////////////////
+ // return pointer to static string containing datetime
+-static char* TimeStr( long lValue )
++static char* TimeStr( time_t lValue )
+ {
+ static char szBuf[ 64 ];
+ struct tm* psDateTime;