aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rioutil
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /audio/rioutil
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'audio/rioutil')
-rw-r--r--audio/rioutil/Makefile15
-rw-r--r--audio/rioutil/files/extra-patch-configure.ac17
2 files changed, 28 insertions, 4 deletions
diff --git a/audio/rioutil/Makefile b/audio/rioutil/Makefile
index 1ad61d795220..f2ae6eef104f 100644
--- a/audio/rioutil/Makefile
+++ b/audio/rioutil/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to inferface with the Rio600, Rio800, and psa[play devices
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,10 +24,19 @@ MAN1= rioutil.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.ac
+USE_AUTOTOOLS= autoconf:262
+.endif
+
post-extract:
- @${RM} -f ${WRKSRC}/src/getopt*
+# @${RM} -f ${WRKSRC}/src/getopt*
# Fix for GCC 4.2
@${REINPLACE_CMD} -e 's,read_buffer = .*),(&),' \
${WRKSRC}/librioutil/rio.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/rioutil/files/extra-patch-configure.ac b/audio/rioutil/files/extra-patch-configure.ac
new file mode 100644
index 000000000000..34d3d9d06a68
--- /dev/null
+++ b/audio/rioutil/files/extra-patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2009-03-07 01:48:24.000000000 +0300
++++ configure.ac 2009-03-07 01:49:07.000000000 +0300
+@@ -74,13 +74,7 @@
+ AC_MSG_RESULT(yes)
+ AC_DEFINE_UNQUOTED(WITH_LIBUSB)
+
+- AC_PATH_PROG(LIBUSB_CONFIG,libusb-config)
+- if test -n "${LIBUSB_CONFIG}"; then
+- CFLAGS="`${LIBUSB_CONFIG} --cflags` $CFLAGS"
+- LIBS="`${LIBUSB_CONFIG} --libs` $LIBS"
+- else
+- AC_MSG_ERROR(Can't find libusb)
+- fi
++ LIBS="-lusb $LIBS"
+
+ AC_CHECK_LIB(usb, usb_open)
+ AC_SUBST(WITH_LIBUSB)