aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ripperx
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-06 06:18:30 +0800
committermiwi <miwi@FreeBSD.org>2007-01-06 06:18:30 +0800
commit8f32792b3995ea23e88718ed011f533df1ec866a (patch)
treeb53087972ad05728939255a37ecc54bc18c4619c /audio/ripperx
parent8b2a955325a23e0c98b714c55c4ad62a05a8c29b (diff)
downloadfreebsd-ports-gnome-8f32792b3995ea23e88718ed011f533df1ec866a.tar.gz
freebsd-ports-gnome-8f32792b3995ea23e88718ed011f533df1ec866a.tar.zst
freebsd-ports-gnome-8f32792b3995ea23e88718ed011f533df1ec866a.zip
RipperX is a GTK program to rip CD audio tracks and encode them
to the Ogg, MP3, or FLAC formats. It is easy, requiring a few mouse clicks to convert an entire album, displaying progress along the way. It can rip and encode in parallel, and supports CDD. WWW: http://sourceforge.net/projects/ripperx/ PR: ports/107493 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Diffstat (limited to 'audio/ripperx')
-rw-r--r--audio/ripperx/Makefile31
-rw-r--r--audio/ripperx/distinfo3
-rw-r--r--audio/ripperx/files/patch-plugins-ripperX_plugin-oggenc.c30
-rw-r--r--audio/ripperx/files/patch-src-Makefile.in11
-rw-r--r--audio/ripperx/files/patch-src-config_rw.c14
-rw-r--r--audio/ripperx/files/patch-src-ripper_encoder_manipulation.c10
-rw-r--r--audio/ripperx/pkg-descr6
-rw-r--r--audio/ripperx/pkg-plist13
8 files changed, 118 insertions, 0 deletions
diff --git a/audio/ripperx/Makefile b/audio/ripperx/Makefile
new file mode 100644
index 000000000000..0dff4810dbe1
--- /dev/null
+++ b/audio/ripperx/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ripperx
+# Date created: 2006-12-26
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ripperx
+PORTVERSION= 2.7.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ripperx
+DISTNAME= ripperX-${PORTVERSION}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= GTK program to rip CD audio tracks and encode them
+
+LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib
+RUN_DEPENDS= cdparanoia:${PORTSDIR}/audio/cdparanoia
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/ripperx/distinfo b/audio/ripperx/distinfo
new file mode 100644
index 000000000000..b6cfeab2e12c
--- /dev/null
+++ b/audio/ripperx/distinfo
@@ -0,0 +1,3 @@
+MD5 (ripperX-2.7.0.tar.gz) = bf69f2cbfb52551ac18e713e9894f306
+SHA256 (ripperX-2.7.0.tar.gz) = af97a0e0951bd6cb7f72e3d0f3c1effbb17832102aac4c5a75910ff2bbca0b7e
+SIZE (ripperX-2.7.0.tar.gz) = 172818
diff --git a/audio/ripperx/files/patch-plugins-ripperX_plugin-oggenc.c b/audio/ripperx/files/patch-plugins-ripperX_plugin-oggenc.c
new file mode 100644
index 000000000000..059fcdbc3f6a
--- /dev/null
+++ b/audio/ripperx/files/patch-plugins-ripperX_plugin-oggenc.c
@@ -0,0 +1,30 @@
+--- plugins/ripperX_plugin-oggenc.c.orig Wed Jan 3 20:15:49 2007
++++ plugins/ripperX_plugin-oggenc.c Wed Jan 3 20:22:39 2007
+@@ -1,5 +1,3 @@
+-// strndup is a GNU extension:
+-#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -8,6 +6,21 @@
+
+ #define OGG_OUTPUT_BUF_LENGTH 2048
+ #define PRINTOUT_INTERVAL 0.5
++
++char
++*strndup(const char *string, size_t n)
++{
++ char *ret = malloc(n + 1);
++
++ if (ret == NULL)
++ return NULL;
++
++ strncpy(ret, string, n);
++
++ ret[n] = '\0';
++
++ return ret;
++}
+
+ void
+ strip_shit(char* input, int len) {
diff --git a/audio/ripperx/files/patch-src-Makefile.in b/audio/ripperx/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..46c3c892e304
--- /dev/null
+++ b/audio/ripperx/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Jan 3 20:11:27 2007
++++ src/Makefile.in Wed Jan 3 20:11:33 2007
+@@ -11,7 +11,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+-LDFLAGS = @LDFLAGS@ @LIBS@ -lutil -lid3
++LDFLAGS = @LDFLAGS@ @LIBS@ -lutil -lid3 -lstdc++
+ INSTALL = @INSTALL@
+
+ CFILES = main.c\
diff --git a/audio/ripperx/files/patch-src-config_rw.c b/audio/ripperx/files/patch-src-config_rw.c
new file mode 100644
index 000000000000..af918d87bef3
--- /dev/null
+++ b/audio/ripperx/files/patch-src-config_rw.c
@@ -0,0 +1,14 @@
+--- src/config_rw.c.orig Wed Jan 3 20:37:27 2007
++++ src/config_rw.c Wed Jan 3 20:38:12 2007
+@@ -84,9 +84,9 @@
+ { "Encoder::Plugin", config.encoder.plugin,
+ STRING, 0, "ripperX_plugin-lame" },
+ { "CdPlayer::Play_command", config.cd_player.play_command,
+- STRING, 0, "cdplay play %" },
++ STRING, 0, "cdcontrol play %" },
+ { "CdPlayer::Stop_command", config.cd_player.stop_command,
+- STRING, 0, "cdplay stop" },
++ STRING, 0, "cdcontrol stop" },
+ { "WavPlayer::Command", config.wav_player.command,
+ STRING, 0, "splay %" },
+ { "Mp3Player::Command", config.mp3_player.command,
diff --git a/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c b/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c
new file mode 100644
index 000000000000..d8ad8cbb587d
--- /dev/null
+++ b/audio/ripperx/files/patch-src-ripper_encoder_manipulation.c
@@ -0,0 +1,10 @@
+--- src/ripper_encoder_manipulation.c.orig Tue Dec 26 22:16:04 2006
++++ src/ripper_encoder_manipulation.c Tue Dec 26 22:16:17 2006
+@@ -11,7 +11,6 @@
+ #include <fcntl.h>
+ #include <sys/wait.h>
+ #include <sys/ioctl.h>
+-#include <pty.h>
+
+ #include "ripper_encoder_manipulation.h"
+ #include "misc_utils.h"
diff --git a/audio/ripperx/pkg-descr b/audio/ripperx/pkg-descr
new file mode 100644
index 000000000000..c0273f471695
--- /dev/null
+++ b/audio/ripperx/pkg-descr
@@ -0,0 +1,6 @@
+RipperX is a GTK program to rip CD audio tracks and encode them
+to the Ogg, MP3, or FLAC formats. It is easy, requiring a few mouse
+clicks to convert an entire album, displaying progress along the
+way. It can rip and encode in parallel, and supports CDD.
+
+WWW: http://sourceforge.net/projects/ripperx/
diff --git a/audio/ripperx/pkg-plist b/audio/ripperx/pkg-plist
new file mode 100644
index 000000000000..230ca31a4905
--- /dev/null
+++ b/audio/ripperx/pkg-plist
@@ -0,0 +1,13 @@
+bin/ripperX
+bin/ripperX_plugin-cdparanoia
+bin/ripperX_plugin-8hz-mp3
+bin/ripperX_plugin-encode
+bin/ripperX_plugin-lame
+bin/ripperX_plugin-gogo
+bin/ripperX_plugin-bladeenc
+bin/ripperX_plugin-xingmp3enc
+bin/ripperX_plugin-l3enc
+bin/ripperX_plugin-mp3enc
+bin/ripperX_plugin-oggenc
+bin/ripperX_plugin-flac
+bin/ripperX_plugin-toolame