aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rosegarden
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-20 18:22:43 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-20 18:22:43 +0800
commitac589b2edfe78c90a71e3f37a37740425a85517c (patch)
tree4f9d1d8a01e854bb71579885d5d2b95ede38f4bf /audio/rosegarden
parentef5df746e3015e417ee0150eec70607a45c8f6dc (diff)
downloadfreebsd-ports-gnome-ac589b2edfe78c90a71e3f37a37740425a85517c.tar.gz
freebsd-ports-gnome-ac589b2edfe78c90a71e3f37a37740425a85517c.tar.zst
freebsd-ports-gnome-ac589b2edfe78c90a71e3f37a37740425a85517c.zip
Update ot 17.04
* drop files/patch-src_gui_application_main.cpp -- it built fine with gcc5 gcc6 and clang without it Approved by: rakuco (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10829
Diffstat (limited to 'audio/rosegarden')
-rw-r--r--audio/rosegarden/Makefile3
-rw-r--r--audio/rosegarden/distinfo6
-rw-r--r--audio/rosegarden/files/patch-src_gui_application_main.cpp30
3 files changed, 4 insertions, 35 deletions
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 4160352fc40e..913472ff5243 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rosegarden
-PORTVERSION= 16.06
-PORTREVISION= 1
+PORTVERSION= 17.04
CATEGORIES= audio
MASTER_SITES= SF
diff --git a/audio/rosegarden/distinfo b/audio/rosegarden/distinfo
index e11a6decf21c..7462718d8781 100644
--- a/audio/rosegarden/distinfo
+++ b/audio/rosegarden/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477047066
-SHA256 (rosegarden-16.06.tar.bz2) = 1044334f2c1a2ac7560d80910e0721c8913bd924f8185a393f630c89020340db
-SIZE (rosegarden-16.06.tar.bz2) = 6362923
+TIMESTAMP = 1495262222
+SHA256 (rosegarden-17.04.tar.bz2) = 988a6141c5b0a8e85c029f650de78bf57100c4d778c22d0194b0692584640ece
+SIZE (rosegarden-17.04.tar.bz2) = 6454603
diff --git a/audio/rosegarden/files/patch-src_gui_application_main.cpp b/audio/rosegarden/files/patch-src_gui_application_main.cpp
deleted file mode 100644
index 9ea2765909aa..000000000000
--- a/audio/rosegarden/files/patch-src_gui_application_main.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/gui/application/main.cpp.orig 2016-02-29 12:18:01 UTC
-+++ src/gui/application/main.cpp
-@@ -359,6 +359,11 @@ void usage()
- exit(2);
- }
-
-+#ifdef __GNUG__
-+#pragma GCC push
-+#pragma GCC diagnostic ignored "-Wunused-variable"
-+#endif
-+
- int main(int argc, char *argv[])
- {
-
-@@ -405,7 +410,6 @@ int main(int argc, char *argv[])
- // (this has to be outside the ifdef block below)
- QSettings preAppSettings("rosegardenmusic", "Rosegarden");
- preAppSettings.beginGroup(GeneralOptionsConfigGroup);
--#pragma GCC diagnostic ignored "-Wunused-variable"
- unsigned int graphicsSystem = preAppSettings.value("graphics_system", Native).toUInt();
- preAppSettings.endGroup();
-
-@@ -868,4 +872,7 @@ int main(int argc, char *argv[])
-
- return returnCode;
- }
-+#ifdef __GNUG__
-+#pragma GCC pop
-+#endif
-