aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ruby-freedb/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-16 19:35:24 +0800
committerknu <knu@FreeBSD.org>2002-01-16 19:35:24 +0800
commit3508be133cf3bfd59837b3e4dbe52eca80c152fe (patch)
tree44ce57624d8b100a3648ab2a16963c629bd8f1a2 /audio/ruby-freedb/Makefile
parent26e63a67b2b54e484ba0753745cc2d6e1edf88ef (diff)
downloadfreebsd-ports-gnome-3508be133cf3bfd59837b3e4dbe52eca80c152fe.tar.gz
freebsd-ports-gnome-3508be133cf3bfd59837b3e4dbe52eca80c152fe.tar.zst
freebsd-ports-gnome-3508be133cf3bfd59837b3e4dbe52eca80c152fe.zip
Add ruby-freedb, a Ruby library that provides access to Freedb/CDDB
servers.
Diffstat (limited to 'audio/ruby-freedb/Makefile')
-rw-r--r--audio/ruby-freedb/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/audio/ruby-freedb/Makefile b/audio/ruby-freedb/Makefile
new file mode 100644
index 000000000000..481903e3128e
--- /dev/null
+++ b/audio/ruby-freedb/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/Freedb
+# Date created: 16 January 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedb
+PORTVERSION= 0.1
+CATEGORIES= audio net ruby
+MASTER_SITES= http://davedd.free.fr/%SUBDIR%/
+MASTER_SITE_SUBDIR= ruby-${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README
+EXAMPLES= test.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>