aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ruby-vorbisfile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-10-05 18:46:55 +0800
committerknu <knu@FreeBSD.org>2002-10-05 18:46:55 +0800
commit7a2262488161dab130aea85fac02291f6b9aff1d (patch)
treef39de1e3c6cff18ef0530a40c87dfd3d749ea701 /audio/ruby-vorbisfile
parent49fb7a70ec84ed9fa46908a233820a8aefa15b2b (diff)
downloadfreebsd-ports-gnome-7a2262488161dab130aea85fac02291f6b9aff1d.tar.gz
freebsd-ports-gnome-7a2262488161dab130aea85fac02291f6b9aff1d.tar.zst
freebsd-ports-gnome-7a2262488161dab130aea85fac02291f6b9aff1d.zip
Add ruby-vorbisfile, a Ruby extension wrapping libvorbisfile.
Diffstat (limited to 'audio/ruby-vorbisfile')
-rw-r--r--audio/ruby-vorbisfile/Makefile37
-rw-r--r--audio/ruby-vorbisfile/distinfo1
-rw-r--r--audio/ruby-vorbisfile/pkg-comment1
-rw-r--r--audio/ruby-vorbisfile/pkg-descr4
-rw-r--r--audio/ruby-vorbisfile/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/ruby-vorbisfile/Makefile b/audio/ruby-vorbisfile/Makefile
new file mode 100644
index 000000000000..c524b7da9b6c
--- /dev/null
+++ b/audio/ruby-vorbisfile/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-vorbisfile
+# Date created: 5 October 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vorbisfile
+PORTVERSION= 0.2
+CATEGORIES= audio ruby
+MASTER_SITES= http://rikkus.info/arch/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= ChangeLog README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/ruby-vorbisfile/distinfo b/audio/ruby-vorbisfile/distinfo
new file mode 100644
index 000000000000..871520f18263
--- /dev/null
+++ b/audio/ruby-vorbisfile/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-vorbisfile-0.2.tar.gz) = 1772ca1c368c527b8809803fb4996b3e
diff --git a/audio/ruby-vorbisfile/pkg-comment b/audio/ruby-vorbisfile/pkg-comment
new file mode 100644
index 000000000000..372c5f247240
--- /dev/null
+++ b/audio/ruby-vorbisfile/pkg-comment
@@ -0,0 +1 @@
+A Ruby extension wrapping libvorbisfile
diff --git a/audio/ruby-vorbisfile/pkg-descr b/audio/ruby-vorbisfile/pkg-descr
new file mode 100644
index 000000000000..ef738dc964c6
--- /dev/null
+++ b/audio/ruby-vorbisfile/pkg-descr
@@ -0,0 +1,4 @@
+ruby-vorbisfile is a Ruby extension wrapping libvorbisfile.
+
+Author: Rik Hemsley <rik@kde.org>
+WWW: http://rikkus.info/ruby_vorbisfile.html
diff --git a/audio/ruby-vorbisfile/pkg-plist b/audio/ruby-vorbisfile/pkg-plist
new file mode 100644
index 000000000000..48929af31c7b
--- /dev/null
+++ b/audio/ruby-vorbisfile/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITEARCHLIBDIR%%/vorbisfile.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/vorbisfile/test.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/vorbisfile
+%%PORTDOCS%%%%RUBY_DOCDIR%%/vorbisfile/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/vorbisfile/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/vorbisfile