aboutsummaryrefslogtreecommitdiffstats
path: root/audio/sdl_mixer
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-31 14:55:52 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-31 14:55:52 +0800
commitb219dc144f620f9f6120e242a744d8f75f4df04a (patch)
tree38520754b05fcb98657c65bfbad1e46dea42df7d /audio/sdl_mixer
parent12af07208b5fc48d64cb2031b2e51dbad61e3335 (diff)
downloadfreebsd-ports-gnome-b219dc144f620f9f6120e242a744d8f75f4df04a.tar.gz
freebsd-ports-gnome-b219dc144f620f9f6120e242a744d8f75f4df04a.tar.zst
freebsd-ports-gnome-b219dc144f620f9f6120e242a744d8f75f4df04a.zip
update audio/sdl_mixer:
- Utilize USE_SDL - PERL -> REINPLACE_CMD PR: 55052 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'audio/sdl_mixer')
-rw-r--r--audio/sdl_mixer/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 607a428e9b70..e4a14a266a8a 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -14,20 +14,20 @@ DISTNAME= SDL_mixer-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A sample multi-channel audio mixer library
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- smpeg.1:${PORTSDIR}/multimedia/smpeg \
- vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
+ smpeg.1:${PORTSDIR}/multimedia/smpeg
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
-USE_LIBTOOL= yes
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${X11BASE}/include"
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
.include <bsd.port.mk>