aboutsummaryrefslogtreecommitdiffstats
path: root/audio/slv2
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-20 21:51:53 +0800
committermarino <marino@FreeBSD.org>2015-02-20 21:51:53 +0800
commitb743bdef51c02bea292c106a008c09912b1e0ea8 (patch)
treeb3252ef8e22f59f38fc85a4370be0001cb20d626 /audio/slv2
parent00f51a6084c52d06960a48f95433567bd955557f (diff)
downloadfreebsd-ports-gnome-b743bdef51c02bea292c106a008c09912b1e0ea8.tar.gz
freebsd-ports-gnome-b743bdef51c02bea292c106a008c09912b1e0ea8.tar.zst
freebsd-ports-gnome-b743bdef51c02bea292c106a008c09912b1e0ea8.zip
audio/slv2: Set the make environment on the do-build target
While here, unmask all the build and install commands.
Diffstat (limited to 'audio/slv2')
-rw-r--r--audio/slv2/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/slv2/Makefile b/audio/slv2/Makefile
index 4b94f3fceeb6..b92a54afcf75 100644
--- a/audio/slv2/Makefile
+++ b/audio/slv2/Makefile
@@ -38,16 +38,18 @@ post-patch:
's|^#define _XOPEN_SOURCE .*||' ${WRKSRC}/src/plugin.c
do-configure:
- @(cd ${WRKSRC} && ${PYTHON_CMD} waf ${WAF_VERBOSE} --prefix=${PREFIX} configure)
+ (cd ${WRKSRC} && ${PYTHON_CMD} \
+ waf ${WAF_VERBOSE} --prefix=${PREFIX} configure)
do-build:
- @(cd ${WRKSRC} && ${PYTHON_CMD} waf ${WAF_VERBOSE} ${WAF_JOBS} build)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
+ waf ${WAF_VERBOSE} ${WAF_JOBS} build)
do-install:
- @(cd ${WRKSRC} && ${PYTHON_CMD} waf ${WAF_VERBOSE} \
- --destdir=${STAGEDIR} install)
+ (cd ${WRKSRC} && ${PYTHON_CMD} \
+ waf ${WAF_VERBOSE} --destdir=${STAGEDIR} install)
.for file in lv2_inspect lv2_jack_host lv2_list lv2_simple_jack_host
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${file}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
.include <bsd.port.post.mk>