aboutsummaryrefslogtreecommitdiffstats
path: root/audio/snd
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 17:33:26 +0800
committerknu <knu@FreeBSD.org>2002-01-29 17:33:26 +0800
commit4da97adde01886935ba4f608070b88f44e9486da (patch)
treea6bb4d3016a5a78eaded12e3c18f3d7d80048702 /audio/snd
parent19d3130df9cdb4623804cf7be13f1ba367a15191 (diff)
downloadfreebsd-ports-gnome-4da97adde01886935ba4f608070b88f44e9486da.tar.gz
freebsd-ports-gnome-4da97adde01886935ba4f608070b88f44e9486da.tar.zst
freebsd-ports-gnome-4da97adde01886935ba4f608070b88f44e9486da.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'audio/snd')
-rw-r--r--audio/snd/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index a3c00c74d805..00a1db1db055 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -81,30 +81,30 @@ post-configure:
@${PERL} -pi -e "s: -ldl::g" ${WRKSRC}/makefile
pre-install:
- ${ECHO} bin/snd > ${PLIST}
+ ${ECHO_CMD} bin/snd > ${PLIST}
.if !defined(WITHOUT_X11)
- ${ECHO} lib/X11/app-defaults/Snd.ad >> ${PLIST}
+ ${ECHO_CMD} lib/X11/app-defaults/Snd.ad >> ${PLIST}
.endif
.for i in audinfo snd-info sndplay sndrecord sndsine
- ${ECHO} bin/${i} >> ${PLIST}
+ ${ECHO_CMD} bin/${i} >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
.for i in COPYING HISTORY.Snd README.Snd TODO.Snd
- ${ECHO} share/doc/snd/${i} >> ${PLIST}
+ ${ECHO_CMD} share/doc/snd/${i} >> ${PLIST}
.endfor
${FIND} ${WRKDIR} -name '*.html' | \
${PERL} -pi -e "s:^${WRKSRC}/:share/doc/snd/:g" >> ${PLIST}
${FIND} ${WRKDIR} -name '*.png' | \
${PERL} -pi -e "s:^${WRKSRC}/:share/doc/snd/:g" >> ${PLIST}
- ${ECHO} "@dirrm share/doc/snd" >> ${PLIST}
+ ${ECHO_CMD} "@dirrm share/doc/snd" >> ${PLIST}
.endif
.if !defined(WITHOUT_GUILE)
${FIND} ${WRKSRC} -name '*.scm' | \
${PERL} -pi -e "s:^${WRKSRC}/:share/snd/:g" >> ${PLIST}
- ${ECHO} "share/snd/contrib/dlp/README" >> ${PLIST}
- ${ECHO} "@dirrm share/snd/contrib/dlp" >> ${PLIST}
- ${ECHO} "@dirrm share/snd/contrib" >> ${PLIST}
- ${ECHO} "@dirrm share/snd" >> ${PLIST}
+ ${ECHO_CMD} "share/snd/contrib/dlp/README" >> ${PLIST}
+ ${ECHO_CMD} "@dirrm share/snd/contrib/dlp" >> ${PLIST}
+ ${ECHO_CMD} "@dirrm share/snd/contrib" >> ${PLIST}
+ ${ECHO_CMD} "@dirrm share/snd" >> ${PLIST}
.endif
do-install: