aboutsummaryrefslogtreecommitdiffstats
path: root/audio/soundtouch/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-06 05:37:38 +0800
committermiwi <miwi@FreeBSD.org>2007-01-06 05:37:38 +0800
commitfc2dd7c90ca1e955444d0660d1273da842de70b8 (patch)
treee7567b8727b2e96ddff7e92036cd7ce41e65e0a3 /audio/soundtouch/Makefile
parent07f8fdcf4a87c7fbb969a913c0f76e8f440324c9 (diff)
downloadfreebsd-ports-gnome-fc2dd7c90ca1e955444d0660d1273da842de70b8.tar.gz
freebsd-ports-gnome-fc2dd7c90ca1e955444d0660d1273da842de70b8.tar.zst
freebsd-ports-gnome-fc2dd7c90ca1e955444d0660d1273da842de70b8.zip
- Update to 1.3.1
PR: ports/106500 Submitted by: trasz <trasz@pin.if.uz.zgora.pl> Approved by: maintainer timeout
Diffstat (limited to 'audio/soundtouch/Makefile')
-rw-r--r--audio/soundtouch/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index 59fb8ffb1e53..0744f6ded9db 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= soundtouch
-DISTVERSION= 1.3.0
+DISTVERSION= 1.3.1
CATEGORIES= audio
-MASTER_SITES= http://users.tkk.fi/~oparviai/
-DISTNAME= ${PORTNAME}_v${PORTVERSION}
+MASTER_SITES= http://www.surina.net/soundtouch/
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open-source audio processing library
GNU_CONFIGURE= yes
-USE_ZIP= yes
+USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/SoundTouch-${PORTVERSION}
+# For some reason this library contains config/ directory with
+# lots of broken symlinks. Remove them here and add new one using
+# files/patch-config. Files were taken from... Audacity, which is
+# distributed with it's own version of SoundTouch ;-)
+pre-patch:
+ ${RM} -rf ${WRKSRC}/config/*
+ ${FIND} ${WRKSRC} -name "Makefile.in*" -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
post-patch: .SILENT
${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|' \
@@ -27,9 +33,16 @@ post-patch: .SILENT
${WRKSRC}/include/Makefile.in ${WRKSRC}/Makefile.in
# Fix for GCC 4.x
${REINPLACE_CMD} -e 's|SoundTouch::||' ${WRKSRC}/include/SoundTouch.h
+ ${CHMOD} +rx ${WRKSRC}/config/install-sh
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/ install-pkgdocDATA$$//' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>