aboutsummaryrefslogtreecommitdiffstats
path: root/audio/soundtouch/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-05-15 22:08:38 +0800
committerdanfe <danfe@FreeBSD.org>2005-05-15 22:08:38 +0800
commit7346b6b8135ed6ca968352154469f6b7f3b9e3bd (patch)
treef28a50484758d7b6965b6bd3510c8f6ae77e5ae7 /audio/soundtouch/Makefile
parentdcd0bbf8066a8dcc105355b2fda3b5c1fe4f7e94 (diff)
downloadfreebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.tar.gz
freebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.tar.zst
freebsd-ports-gnome-7346b6b8135ed6ca968352154469f6b7f3b9e3bd.zip
Add SoundTouch 1.3.0, an open-source audio processing library for changing
the Tempo, Pitch and Playback Rates of audio streams or files. WWW: http://sky.prohosting.com/oparviai/soundtouch/
Diffstat (limited to 'audio/soundtouch/Makefile')
-rw-r--r--audio/soundtouch/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
new file mode 100644
index 000000000000..1d483cd10dcf
--- /dev/null
+++ b/audio/soundtouch/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: SoundTouch
+# Date created: 16 May 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soundtouch
+DISTVERSION= 1.3.0
+CATEGORIES= audio
+MASTER_SITES= http://sky.prohosting.com/oparviai/soundtouch/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= An open-source audio processing library
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/SoundTouch-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|' \
+ ${WRKSRC}/source/example/bpm/Makefile.in \
+ ${WRKSRC}/source/example/SoundStretch/Makefile.in \
+ ${WRKSRC}/source/SoundTouch/Makefile.in \
+ ${WRKSRC}/include/Makefile.in ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's/ install-pkgdocDATA$$//' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>