aboutsummaryrefslogtreecommitdiffstats
path: root/audio/sox/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-10-23 02:44:30 +0800
committersf <sf@FreeBSD.org>2001-10-23 02:44:30 +0800
commiteba00b6aae15fcd1ab16c12fd939626e5016060e (patch)
treef890e1608893ae1a78f75bd4209fb0bf0778b527 /audio/sox/Makefile
parentaf3297a496506d4981c7b090f33f569dcf2944bd (diff)
downloadfreebsd-ports-gnome-eba00b6aae15fcd1ab16c12fd939626e5016060e.tar.gz
freebsd-ports-gnome-eba00b6aae15fcd1ab16c12fd939626e5016060e.tar.zst
freebsd-ports-gnome-eba00b6aae15fcd1ab16c12fd939626e5016060e.zip
o unbreak Alpha and prepare for other 64-bit platforms.
o add WITH_VORBIS and fix WITH_GSM. PR: 31413 Submitted by: Christian Weisgerber <naddy@mips.inka.de>, Dan Nelson <dnelson@allantgroup.com> (maintainer)
Diffstat (limited to 'audio/sox/Makefile')
-rw-r--r--audio/sox/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index 934df14e8d08..7e34200d620a 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -7,20 +7,32 @@
PORTNAME= sox
PORTVERSION= 12.17.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sox
-MAINTAINER= dnelson@emsphone.com
+MAINTAINER= dnelson@emsphone.com
-MAN1= sox.1 play.1 soxexam.1
-MLINKS= play.1 rec.1
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-fast-ulaw --enable-fast-alaw
+MAN1= sox.1 play.1 soxexam.1
+MLINKS= play.1 rec.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-fast-ulaw --enable-fast-alaw
.if defined(WITH_GSM)
-CONFIGURE_ARGS+= --with-gsmlib=${PREFIX}/lib --with-gsminc=${PREFIX}/include
-LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+CONFIGURE_ARGS+= --with-gsmlib=${LOCALBASE}/lib \
+ --with-gsminc=${LOCALBASE}/include
+LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+.else
+CONFIGURE_ARGS+= --with-gsminc=no
+.endif
+
+.if defined(WITH_VORBIS)
+CONFIGURE_ARGS+= --with-ogg-vorbisinc=${LOCALBASE}/include \
+ --with-ogg-vorbislib=${LOCALBASE}/lib
+LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+= --with-ogg-vorbisinc=no
.endif
.include <bsd.port.mk>