aboutsummaryrefslogtreecommitdiffstats
path: root/audio/spiralsynth/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-09-17 03:02:06 +0800
committerwill <will@FreeBSD.org>2000-09-17 03:02:06 +0800
commita09cbd37bde85cb97e00d0523333277e7b05e820 (patch)
tree019758a2d9a47b39a087d3d0a99e69e0ff490a04 /audio/spiralsynth/Makefile
parent2e7f5e6bf50bf3f317ceeba5b8fa97175f6fef7a (diff)
downloadfreebsd-ports-gnome-a09cbd37bde85cb97e00d0523333277e7b05e820.tar.gz
freebsd-ports-gnome-a09cbd37bde85cb97e00d0523333277e7b05e820.tar.zst
freebsd-ports-gnome-a09cbd37bde85cb97e00d0523333277e7b05e820.zip
Add spiralsynth 0.1.5, a nifty program that generates noise or music
(depending on the talents of the user) from a MIDI or PC keyboard, and outputs to /dev/dsp or to a .wav file. PR: 21053 Submitted by: Trevor Johnson <trevor@jpj.net>
Diffstat (limited to 'audio/spiralsynth/Makefile')
-rw-r--r--audio/spiralsynth/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
new file mode 100644
index 000000000000..d9323821d1c1
--- /dev/null
+++ b/audio/spiralsynth/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: spiralsynth
+# Date created: 2000-09-05
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $FreeBSD$
+#
+
+PORTNAME= spiralsynth
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= http://www.blueammonite.f9.co.uk/SpiralSynth/dload/ \
+ http://jpj.net/~trevor/freebsd/ports/
+DISTNAME= SpiralSynth-${PORTVERSION}
+
+MAINTAINER= trevor@jpj.net
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_X_PREFIX= yes
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+DOC_FILES= CHANGES COPYING README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/SpiralSynth ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/spiralsynth
+.for i in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/spiralsynth
+.endfor
+.endif
+.include <bsd.port.mk>