aboutsummaryrefslogtreecommitdiffstats
path: root/audio/spiralsynth
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-10-04 22:58:59 +0800
committertrevor <trevor@FreeBSD.org>2003-10-04 22:58:59 +0800
commitbce29209000beec9504053798e91a160ff85909f (patch)
treed4427fef48eeba537855569a7b6fc7d8c700d7de /audio/spiralsynth
parent0b96bdfadbfcf8b374b9ef0e255c412cee9c59a3 (diff)
downloadfreebsd-ports-gnome-bce29209000beec9504053798e91a160ff85909f.tar.gz
freebsd-ports-gnome-bce29209000beec9504053798e91a160ff85909f.tar.zst
freebsd-ports-gnome-bce29209000beec9504053798e91a160ff85909f.zip
Avoid Perl.
PR: 47651 Submitted by: Simon Schubert of ath.cx
Diffstat (limited to 'audio/spiralsynth')
-rw-r--r--audio/spiralsynth/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 3a8638e6e3c7..235edcd50d01 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -33,16 +33,19 @@ BROKEN= "Does not compile (bad C++ code)"
.endif
post-patch:
- ${PERL} -pi -e 's|-O3|${PTHREAD_CFLAGS}|g ; \
+.for ii in Makefile.in PluginLink.sh
+ ${MV} ${WRKSRC}/${ii} ${WRKSRC}/${ii}.orig
+ ${SED} -e 's|-O3|${PTHREAD_CFLAGS}|g ; \
s|CFLAGS =|CFLAGS +=|g ; \
s|CXXFLAGS=|CXXFLAGS+=|g ; \
s|-lm|${PTHREAD_LIBS} -lm|g ; \
- s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/PluginLink.sh
+ s|/usr/X11R6|${X11BASE}|g' < ${ii}.orig > ${ii}
+.endfor
# Use as a plugin to SpiralLoops 2.0.0 results in "Can't open audio driver."
.if defined(PLUGIN)
- ${PERL} -pi -e 's|^//#define PLUGIN|#define PLUGIN|g' \
- ${WRKSRC}/Synth.C
+ ${MV} ${WRKSRC}/Synth.C ${WRKSRC}/Synth.C.orig
+ ${SED} -e 's|^//#define PLUGIN|#define PLUGIN|g' \
+ < ${WRKSRC}/Synth.C.orig > ${WRKSRC}/Synth.C
post-build:
cd ${WRKSRC}; ${SH} ./PluginLink.sh