aboutsummaryrefslogtreecommitdiffstats
path: root/audio/spiralsynthmodular
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-12-27 07:34:51 +0800
committermiwi <miwi@FreeBSD.org>2011-12-27 07:34:51 +0800
commit821fe076278c963432ec7c6a9039b21bc762a230 (patch)
treece1a2552c0974bd5775904bf1d4ec47bee054ed6 /audio/spiralsynthmodular
parent74722fa079e1d59d42e6e5f0aaf1d7adb4ac0112 (diff)
downloadfreebsd-ports-gnome-821fe076278c963432ec7c6a9039b21bc762a230.tar.gz
freebsd-ports-gnome-821fe076278c963432ec7c6a9039b21bc762a230.tar.zst
freebsd-ports-gnome-821fe076278c963432ec7c6a9039b21bc762a230.zip
- Unbreak build with lang/gcc46
PR: 163346 Submitted by: Jan Beich <jbeich@tormail.net>
Diffstat (limited to 'audio/spiralsynthmodular')
-rw-r--r--audio/spiralsynthmodular/Makefile6
-rw-r--r--audio/spiralsynthmodular/files/patch-gcc4632
2 files changed, 35 insertions, 3 deletions
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 4a32bbc48004..3837d0a34e74 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -79,9 +79,9 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -E -e \
's|-ldl||; \
s|-lrt||; \
- s|^CC[[:space:]]*=.+$$|CC=${CC}|; \
- s|^CXX[[:space:]]*=.+$$|CXX=${CXX}|; \
- s|g\+\+|${CXX}|; \
+ s|g\+\+|$$(CXX)|; \
+ /^CC[[:space:]]*=.+$$/d; \
+ /^CXX[[:space:]]*=.+$$/d; \
s,@FLTK_(C|CXX)FLAGS@,-I${LOCALBASE}/include,; \
s|-lpthread|${PTHREAD_LIBS}|g'
diff --git a/audio/spiralsynthmodular/files/patch-gcc46 b/audio/spiralsynthmodular/files/patch-gcc46
new file mode 100644
index 000000000000..75f9e77444f1
--- /dev/null
+++ b/audio/spiralsynthmodular/files/patch-gcc46
@@ -0,0 +1,32 @@
+--- SpiralSound/ChannelHandler.C~
++++ SpiralSound/ChannelHandler.C
+@@ -19,6 +19,9 @@
+ #include "ChannelHandler.h"
+ #include <unistd.h>
+
++#include <cstdlib>
++#include <cstring>
++
+ using namespace std;
+
+ //#define CHANNEL_DEBUG
+--- SpiralSound/Plugins/LADSPAPlugin/LADSPAInfo.C~
++++ SpiralSound/Plugins/LADSPAPlugin/LADSPAInfo.C
+@@ -30,6 +30,7 @@
+ #include <stdio.h>
+
+ #include <cstdlib>
++#include <cstring>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
+--- SpiralSound/Sample.h~
++++ SpiralSound/Sample.h
+@@ -23,6 +23,7 @@
+
+ #include <assert.h>
+ #include <limits.h>
++#include <cstring>
+ #include <iostream>
+
+ //#define DEBUG