aboutsummaryrefslogtreecommitdiffstats
path: root/audio/splaytk/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-04-24 10:33:35 +0800
committermph <mph@FreeBSD.org>1998-04-24 10:33:35 +0800
commitff90bccc2e4d72ea7eaad80aa85a1aa8a90e1bb2 (patch)
treed711c615c9ecc4693a86b03ecdb14b24b9fcb99e /audio/splaytk/Makefile
parent161f940e1376e386a2f85148cc57fb11c81fcf73 (diff)
downloadfreebsd-ports-gnome-ff90bccc2e4d72ea7eaad80aa85a1aa8a90e1bb2.tar.gz
freebsd-ports-gnome-ff90bccc2e4d72ea7eaad80aa85a1aa8a90e1bb2.tar.zst
freebsd-ports-gnome-ff90bccc2e4d72ea7eaad80aa85a1aa8a90e1bb2.zip
Import of splaytk, a Tcl/Tk front-end to the splay mp3 player.
PR: 6352 Submitted by: Brett Taylor <brett@peloton.physics.montana.edu>
Diffstat (limited to 'audio/splaytk/Makefile')
-rw-r--r--audio/splaytk/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/splaytk/Makefile b/audio/splaytk/Makefile
new file mode 100644
index 000000000000..98cc35a804ec
--- /dev/null
+++ b/audio/splaytk/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: splaytk
+# Version required: 2.0
+# Date created: 19 Apr 1998
+# Whom: brett@peloton.physics.montana.edu
+#
+# $Id:$
+#
+
+DISTNAME= splaytk-2.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/players
+
+MAINTAINER= brett@peloton.physics.montana.edu
+
+RUN_DEPENDS= splay:${PORTSDIR}/audio/splay \
+ wish8.0:${PORTSDIR}/x11/tk80
+
+WRKSRC= ${WRKDIR}/splay-tk-2.0
+
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/splay-tk.tcl ${PREFIX}/bin/splay-tk
+ @${MKDIR} ${PREFIX}/lib/splay-tk
+ @${INSTALL_DATA} ${WRKSRC}/*.xbm ${PREFIX}/lib/splay-tk
+ @${INSTALL_DATA} ${WRKSRC}/splay-tk.gif ${PREFIX}/lib/splay-tk
+
+.include <bsd.port.mk>