aboutsummaryrefslogtreecommitdiffstats
path: root/audio/squeezeboxserver-sqlplaylist
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2008-06-30 06:05:56 +0800
committertdb <tdb@FreeBSD.org>2008-06-30 06:05:56 +0800
commitae1be63a41fea952612c94364fdbf51997930437 (patch)
tree35e1065044f564a6ab40023d87d9e2aa9cf4d034 /audio/squeezeboxserver-sqlplaylist
parent0e90d1254bf903bb47cb7efb6ada0863cff61a63 (diff)
downloadfreebsd-ports-gnome-ae1be63a41fea952612c94364fdbf51997930437.tar.gz
freebsd-ports-gnome-ae1be63a41fea952612c94364fdbf51997930437.tar.zst
freebsd-ports-gnome-ae1be63a41fea952612c94364fdbf51997930437.zip
This plugin for SqueezeCenter makes it possible to create smart
playlists. Although the standard SqueezeCenter doesn't support smart playlists by itself, together with iTunes and the standard SqueezeCenter iTunes integration, it is possible to use smart playlists defined in iTunes. The problem though is that the integrated iTunes smart playlists will not be recalculated until the next time you perform a rescan in SqueezeCenter. The SQL Playlist plugin takes care of this problem and implements native smart playlist in SqueezeCenter without any need to use iTunes. The smart playlists implemented in SQL Playlist will also be automatically re-calculated after each track played so they will be based on the latest statistic information. A smart playlist in SQL Playlist are continous and will run forever in the same way as the standard Random Mix plugin, you can optionally also choose that a smart playlist shouldn't repeat already played tracks and in that case the music will stop when all songs matching the playlist has been played. WWW: http://wiki.slimdevices.com/index.php/SQL_Playlist_plugin
Diffstat (limited to 'audio/squeezeboxserver-sqlplaylist')
-rw-r--r--audio/squeezeboxserver-sqlplaylist/Makefile34
-rw-r--r--audio/squeezeboxserver-sqlplaylist/distinfo3
-rw-r--r--audio/squeezeboxserver-sqlplaylist/pkg-descr20
-rw-r--r--audio/squeezeboxserver-sqlplaylist/pkg-plist75
4 files changed, 132 insertions, 0 deletions
diff --git a/audio/squeezeboxserver-sqlplaylist/Makefile b/audio/squeezeboxserver-sqlplaylist/Makefile
new file mode 100644
index 000000000000..8511a102a252
--- /dev/null
+++ b/audio/squeezeboxserver-sqlplaylist/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: squeezecenter-sqlplaylist
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlplaylist
+PORTVERSION= 2.0.b04
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-sqlplaylist&filename=/
+PKGNAMEPREFIX= squeezecenter-
+DISTNAME= SQLPlayList-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin to create playlists based on SQL queries
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter \
+ ${LOCALBASE}/${SLIMDIR}/Plugins/DynamicPlayList/install.xml:${PORTSDIR}/audio/squeezecenter-dynamicplaylist
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+ ${CP} -R ${WRKSRC}/SQLPlayList/* ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+
+.include <bsd.port.mk>
diff --git a/audio/squeezeboxserver-sqlplaylist/distinfo b/audio/squeezeboxserver-sqlplaylist/distinfo
new file mode 100644
index 000000000000..2fdce32b7dd1
--- /dev/null
+++ b/audio/squeezeboxserver-sqlplaylist/distinfo
@@ -0,0 +1,3 @@
+MD5 (squeezecenter/SQLPlayList-2.0.beta04.zip) = 597121510bff520eaa7882a906582011
+SHA256 (squeezecenter/SQLPlayList-2.0.beta04.zip) = e0db5526ee685106284f8915b871104d39b3937f783f5dce870b68cdadff534c
+SIZE (squeezecenter/SQLPlayList-2.0.beta04.zip) = 215636
diff --git a/audio/squeezeboxserver-sqlplaylist/pkg-descr b/audio/squeezeboxserver-sqlplaylist/pkg-descr
new file mode 100644
index 000000000000..b04957f64ff4
--- /dev/null
+++ b/audio/squeezeboxserver-sqlplaylist/pkg-descr
@@ -0,0 +1,20 @@
+This plugin for SqueezeCenter makes it possible to create smart
+playlists. Although the standard SqueezeCenter doesn't support smart
+playlists by itself, together with iTunes and the standard
+SqueezeCenter iTunes integration, it is possible to use smart
+playlists defined in iTunes. The problem though is that the integrated
+iTunes smart playlists will not be recalculated until the next time
+you perform a rescan in SqueezeCenter. The SQL Playlist plugin takes
+care of this problem and implements native smart playlist in
+SqueezeCenter without any need to use iTunes. The smart playlists
+implemented in SQL Playlist will also be automatically re-calculated
+after each track played so they will be based on the latest statistic
+information.
+
+A smart playlist in SQL Playlist are continous and will run forever in
+the same way as the standard Random Mix plugin, you can optionally
+also choose that a smart playlist shouldn't repeat already played
+tracks and in that case the music will stop when all songs matching
+the playlist has been played.
+
+WWW: http://wiki.slimdevices.com/index.php/SQL_Playlist_plugin
diff --git a/audio/squeezeboxserver-sqlplaylist/pkg-plist b/audio/squeezeboxserver-sqlplaylist/pkg-plist
new file mode 100644
index 000000000000..250e142f5263
--- /dev/null
+++ b/audio/squeezeboxserver-sqlplaylist/pkg-plist
@@ -0,0 +1,75 @@
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default/plugins/SQLPlayList/dynamicplaylistlink.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/catchtab.js
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/dynamicplaylistlink.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/settings/basic.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/settings/subpage_chooser.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_list.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_redirect.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_reload.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_edititem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_editsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_login.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemtypes.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_publishitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_register.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_savedownloadeditem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/LICENSE.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbums.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomartists.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomtracks.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomyears.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/README.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/install.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/Plugins-SQLPlayList-Plugin.par
+%%SLIMDIR%%/Plugins/SQLPlayList/strings.txt
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/lib
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/Templates
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/Playlists
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/settings
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default/plugins/SQLPlayList
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default/plugins
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList
+@dirrmtry %%SLIMDIR%%/Plugins
+@dirrmtry %%SLIMDIR%%