aboutsummaryrefslogtreecommitdiffstats
path: root/audio/squeezeboxserver
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-07-10 01:44:14 +0800
committercrees <crees@FreeBSD.org>2011-07-10 01:44:14 +0800
commit539b972d86a1bce2bb8cf2265f83165b31425713 (patch)
tree355f14e70ee94089c002c469008e82b95858f802 /audio/squeezeboxserver
parentbd27e73b6dd3daa0d281e3ad9219112240ebb181 (diff)
downloadfreebsd-ports-gnome-539b972d86a1bce2bb8cf2265f83165b31425713.tar.gz
freebsd-ports-gnome-539b972d86a1bce2bb8cf2265f83165b31425713.tar.zst
freebsd-ports-gnome-539b972d86a1bce2bb8cf2265f83165b31425713.zip
- Use USERS and GROUPS
- Remove redundant PKGINSTALL assignment PR: ports/157535 Submitted by: crees (me) Approved by: rene (mentor, implicit), maintainer timeout (brooks, 35 days)
Diffstat (limited to 'audio/squeezeboxserver')
-rw-r--r--audio/squeezeboxserver/Makefile4
-rw-r--r--audio/squeezeboxserver/files/pkg-install.in30
2 files changed, 3 insertions, 31 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 60b39861b53e..176faf32dbc1 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -50,8 +50,8 @@ RUN_DEPENDS+= ${SITE_PERL}/DBIx/Class.pm:${PORTSDIR}/databases/p5-DBIx-Class \
# Work around a bug in p5-Package-Stash port
RUN_DEPENDS+= p5-Package-DeprecationManager>=0.10:${PORTSDIR}/devel/p5-Package-DeprecationManager
-PKGINSTALL= ${WRKDIR}/pkg-install
-
+USERS= ${SLIMUSER}
+GROUPS= ${SLIMGROUP}
USE_PERL5= yes
.include <bsd.port.pre.mk>
diff --git a/audio/squeezeboxserver/files/pkg-install.in b/audio/squeezeboxserver/files/pkg-install.in
index 98afb07f95f8..f3fd1d166073 100644
--- a/audio/squeezeboxserver/files/pkg-install.in
+++ b/audio/squeezeboxserver/files/pkg-install.in
@@ -1,12 +1,7 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/audio/squeezeboxserver/files/pkg-install.in,v 1.10 2009-10-14 22:33:31 brooks Exp $
+# $FreeBSD: /tmp/pcvs/ports/audio/squeezeboxserver/files/pkg-install.in,v 1.11 2011-07-09 17:44:14 crees Exp $
name=%%PORTNAME%%
-u=%%SLIMUSER%%
-g=%%SLIMGROUP%%
-ugid=104
-homedir=/nonexistent
-shell=/sbin/nologin
comment="Slim Devices SlimServer/SqueezeCenter pseudo-user"
slimdir="%%PREFIX%%/%%SLIMDIR%%"
statedir=%%SLIMDBDIR%%
@@ -23,29 +18,6 @@ serverlogfile=/var/log/${name}/server.log
serverlogline="${serverlogfile} ${u}:${g} 644 3 100 * J ${pidfile}"
case $2 in
-PRE-INSTALL)
- if pw group show "${g}" >/dev/null 2>&1; then
- echo "Using existing group \"${g}\"."
- else
- echo "Creating group \"${g}\", (gid: ${ugid})."
- pw groupadd ${g} -g ${ugid}
- if [ $? != 0 ]; then
- echo "Failed to add group \"${g}\"."
- exit 1
- fi
- fi
- if pw user show "${u}" >/dev/null 2>&1; then
- echo "Using existing user \"${u}\"."
- else
- echo "Creating user \"${u}\", (uid: ${ugid})."
- pw useradd ${u} -u ${ugid} -g ${ugid} -h - \
- -d ${homedir} -s ${shell} -c "${comment}"
- if [ $? != 0 ]; then
- echo "Failed to add user \"${u}\"."
- exit 1
- fi
- fi
- ;;
POST-INSTALL)
if egrep -q "^${serverlogfile}\>" ${newsyslogfile}; then
echo "Using existing ${newsyslogfile} entry."