aboutsummaryrefslogtreecommitdiffstats
path: root/audio/squeezecenter
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2008-10-07 22:51:08 +0800
committerbrooks <brooks@FreeBSD.org>2008-10-07 22:51:08 +0800
commit1a9ddd09c2d563d2a7d9da4d4e2dcc78fd752bb9 (patch)
tree8cc6cc85645c6071128a7c730869512d0ecc09a3 /audio/squeezecenter
parentd8d0a6a6d68448cde8bc6e6b0262b32fee6e0fd6 (diff)
downloadfreebsd-ports-gnome-1a9ddd09c2d563d2a7d9da4d4e2dcc78fd752bb9.tar.gz
freebsd-ports-gnome-1a9ddd09c2d563d2a7d9da4d4e2dcc78fd752bb9.tar.zst
freebsd-ports-gnome-1a9ddd09c2d563d2a7d9da4d4e2dcc78fd752bb9.zip
Fix the LastFM plugin. It was broken due to the FreeBSD version of JSON::XS
being newer than expected and the general workaround not being implemented in this plugin. Submitted by: tdb
Diffstat (limited to 'audio/squeezecenter')
-rw-r--r--audio/squeezecenter/Makefile2
-rw-r--r--audio/squeezecenter/files/patch-Slim_Plugin_LastFM_ProtocolHandler.pm23
2 files changed, 24 insertions, 1 deletions
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index 052e70533f12..f7be2bf1332d 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squeezecenter
PORTVERSION= 7.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeCenter_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.0//}-noCPAN
diff --git a/audio/squeezecenter/files/patch-Slim_Plugin_LastFM_ProtocolHandler.pm b/audio/squeezecenter/files/patch-Slim_Plugin_LastFM_ProtocolHandler.pm
new file mode 100644
index 000000000000..a715f36e5f98
--- /dev/null
+++ b/audio/squeezecenter/files/patch-Slim_Plugin_LastFM_ProtocolHandler.pm
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- Slim/Plugin/LastFM/ProtocolHandler.pm.orig
++++ Slim/Plugin/LastFM/ProtocolHandler.pm
+@@ -7,7 +7,7 @@
+ use strict;
+ use base qw(Slim::Player::Protocols::HTTP);
+
+-use JSON::XS qw(from_json);
++use JSON::XS qw(decode_json);
+ use URI::Escape qw(uri_escape_utf8);
+
+ use Slim::Player::Playlist;
+@@ -155,7 +155,7 @@
+ my $client = $http->params->{client};
+ my $params = $http->params->{params};
+
+- my $track = eval { from_json( $http->content ) };
++ my $track = eval { decode_json( $http->content ) };
+
+ if ( $@ || $track->{error} ) {
+ # We didn't get the next track to play