aboutsummaryrefslogtreecommitdiffstats
path: root/audio/squeezecenter
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2005-10-19 03:45:10 +0800
committerbrooks <brooks@FreeBSD.org>2005-10-19 03:45:10 +0800
commit9e30852fb15745f44f7f06fa6fb09a8e184faf8a (patch)
treedc96294405a3d06a353c2cab73ced82c52f47e25 /audio/squeezecenter
parentcc022c5537289b5ca9606f6eb78c59958e85f042 (diff)
downloadfreebsd-ports-gnome-9e30852fb15745f44f7f06fa6fb09a8e184faf8a.tar.gz
freebsd-ports-gnome-9e30852fb15745f44f7f06fa6fb09a8e184faf8a.tar.zst
freebsd-ports-gnome-9e30852fb15745f44f7f06fa6fb09a8e184faf8a.zip
Override hardcoding of libexpat search paths in internal build of
XML-Parser to allow an alternate LOCALBASE to work. Reported by: dosirak (via kris)
Diffstat (limited to 'audio/squeezecenter')
-rw-r--r--audio/squeezecenter/Makefile1
-rw-r--r--audio/squeezecenter/files/patch-Bin_build-perl-modules.pl22
2 files changed, 19 insertions, 4 deletions
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index 5d054ed2b1f0..f6bcc1a8b863 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -90,6 +90,7 @@ post-fetch:
post-patch:
${REINPLACE_CMD} \
-e 's|%%PERL%%|${PERL}|' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|' \
-e 's|%%CPANWRKDIR%%|${CPANWRKDIR}|' \
-e 's|%%DISTDIR%%|${_DISTDIR}|' ${WRKSRC}/Bin/build-perl-modules.pl
diff --git a/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl b/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
index 4e2fab43e13f..0c4f4afcf27f 100644
--- a/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
+++ b/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
@@ -3,7 +3,21 @@ $FreeBSD$
--- Bin/build-perl-modules.pl.orig
+++ Bin/build-perl-modules.pl
-@@ -74,28 +74,30 @@
+@@ -54,6 +54,13 @@
+
+ 'env' => [qw(DBI-1.46/blib/lib: DBI-1.46/blib/arch)],
+ },
++
++ 'XML-Parser-2.34' => {
++ 'Makefile.PL' => join(' ', qw(
++ EXPATLIBPATH="%%LOCALBASE%%/lib"
++ EXPATINCPATH="%%LOCALBASE%%/include"
++ )),
++ },
+ );
+
+ sub main {
+@@ -74,28 +81,30 @@
print "*** Ignore any warnings about AppConfig. ***\n\n";
@@ -51,7 +65,7 @@ $FreeBSD$
unless (-d $slimServerPath) {
die "Couldn't find a valid SlimServer path. Exiting.\n";
-@@ -104,12 +106,13 @@
+@@ -107,12 +116,13 @@
# This is where the binaries will end up.
my $cpanDest = "$slimServerPath/CPAN/arch/$version/$archname/auto";
@@ -71,7 +85,7 @@ $FreeBSD$
# Remove trailing slash
$downloadPath =~ s|^(.+?)/$|$1|;
-@@ -122,32 +125,32 @@
+@@ -125,32 +135,32 @@
my $pwd = cwd();
@@ -130,7 +144,7 @@ $FreeBSD$
for my $package (@packages) {
-@@ -158,18 +161,19 @@
+@@ -161,18 +171,19 @@
# Remove any previous version.
unlink $package;