aboutsummaryrefslogtreecommitdiffstats
path: root/audio/tap-plugins/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-05-20 06:16:02 +0800
committerarved <arved@FreeBSD.org>2004-05-20 06:16:02 +0800
commit56f1c17c890e40bc982330d44f319fe73a016d36 (patch)
tree6ff10b407e9c1a51fe87f58175a7092ab7fa935d /audio/tap-plugins/Makefile
parent5eda5a625eff6299d24399e179a886481d3ade14 (diff)
downloadfreebsd-ports-gnome-56f1c17c890e40bc982330d44f319fe73a016d36.tar.gz
freebsd-ports-gnome-56f1c17c890e40bc982330d44f319fe73a016d36.tar.zst
freebsd-ports-gnome-56f1c17c890e40bc982330d44f319fe73a016d36.zip
Add tap-plugins, Tom Szilagyi's collection of LADSPA plugins.
Diffstat (limited to 'audio/tap-plugins/Makefile')
-rw-r--r--audio/tap-plugins/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/tap-plugins/Makefile b/audio/tap-plugins/Makefile
new file mode 100644
index 000000000000..faf0b54f004f
--- /dev/null
+++ b/audio/tap-plugins/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: tap-plugins
+# Date created: 2004-05-19
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= tap-plugins
+PORTVERSION= 0.5.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tap-plugins
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= LADSPA Plugins by Tom Szilagy
+
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lrt,,; \
+ s,-O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math,${CFLAGS}," \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/ladspa
+ ${INSTALL_DATA} ${WRKSRC}/*.so ${PREFIX}/lib/ladspa/
+ ${MKDIR} ${PREFIX}/share/ladspa/rdf/
+ ${INSTALL_DATA} ${WRKSRC}/tap-plugins.rdf ${PREFIX}/share/ladspa/rdf/
+
+.include <bsd.port.mk>