aboutsummaryrefslogtreecommitdiffstats
path: root/audio/tap-plugins/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-07-14 20:19:27 +0800
committerkrion <krion@FreeBSD.org>2004-07-14 20:19:27 +0800
commitaacbd1e52bb5330d12d4ebf0b8c1487d5243126a (patch)
treeaf7afaa2fbc22473e0504e852a4ad8c4894e2615 /audio/tap-plugins/Makefile
parent8e981d6486f293d7e24614f203f307a57bcef9e9 (diff)
downloadfreebsd-ports-gnome-aacbd1e52bb5330d12d4ebf0b8c1487d5243126a.tar.gz
freebsd-ports-gnome-aacbd1e52bb5330d12d4ebf0b8c1487d5243126a.tar.zst
freebsd-ports-gnome-aacbd1e52bb5330d12d4ebf0b8c1487d5243126a.zip
Update to version 0.6.0
PR: ports/68998 Submitted by: Ports Fury
Diffstat (limited to 'audio/tap-plugins/Makefile')
-rw-r--r--audio/tap-plugins/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/tap-plugins/Makefile b/audio/tap-plugins/Makefile
index faf0b54f004f..e10eaa7a6b18 100644
--- a/audio/tap-plugins/Makefile
+++ b/audio/tap-plugins/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= tap-plugins
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tap-plugins
@@ -14,12 +14,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= LADSPA Plugins by Tom Szilagy
USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I. -c -fPIC -DPIC" \
+ LDFLAGS="-nostartfiles -shared -Wl,-Bsymbolic -lm"
post-patch:
- ${REINPLACE_CMD} -e "s,-lrt,,; \
- s,-O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math,${CFLAGS}," \
- ${WRKSRC}/Makefile
+ @${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<inttypes.h>|g'
do-install:
${MKDIR} ${PREFIX}/lib/ladspa