aboutsummaryrefslogtreecommitdiffstats
path: root/audio/teamspeak_client/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-04-09 00:44:27 +0800
committerjylefort <jylefort@FreeBSD.org>2006-04-09 00:44:27 +0800
commit41719f9fdb2574534cfb012ed1b87df3f2ebc08e (patch)
treec94d5bc803b05f8c4ce6a715c905e13558260aac /audio/teamspeak_client/Makefile
parent6d8c29af71546156568d580fc132b9870df2202e (diff)
downloadfreebsd-ports-gnome-41719f9fdb2574534cfb012ed1b87df3f2ebc08e.tar.gz
freebsd-ports-gnome-41719f9fdb2574534cfb012ed1b87df3f2ebc08e.tar.zst
freebsd-ports-gnome-41719f9fdb2574534cfb012ed1b87df3f2ebc08e.zip
- Add a menu item
- Add amd64 to ONLY_FOR_ARCHS (I can not test this, but it should work) - Use exec in the wrapper script: http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/dads-sh-exec.html - Install with ${INSTALL_PROGRAM} and ${INSTALL_DATA}, to ensure proper permissions/stripping/ownerships - This program uses X: move to ${X11BASE} - Install documentation in ${DOCSDIR} - Cleanups (SUB_FILES, PORTDOCS) PR: ports/93931 Submitted by: jylefort Approved by: maintainer timeout (39 days)
Diffstat (limited to 'audio/teamspeak_client/Makefile')
-rw-r--r--audio/teamspeak_client/Makefile55
1 files changed, 48 insertions, 7 deletions
diff --git a/audio/teamspeak_client/Makefile b/audio/teamspeak_client/Makefile
index 18d151392e76..c1657744fc51 100644
--- a/audio/teamspeak_client/Makefile
+++ b/audio/teamspeak_client/Makefile
@@ -7,6 +7,7 @@
PORTNAME= teamspeak_client
PORTVERSION= 2.0.32
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.freenet.de/pub/4players/teamspeak.org/releases/:main \
http://www.gsoft.com.au/~doconnor/:misc
@@ -19,17 +20,57 @@ COMMENT= Client side of a group voice chat system
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
+TSIMG= ${WRKSRC}/setup.data/image
+TSHOME= ${PREFIX}/lib/teamspeak_client
+
+SUB_FILES= TeamSpeak
+SUB_LIST= TSHOME="${TSHOME}"
+
+PORTDOCS= *
+
+DESKTOP_ENTRIES="TeamSpeak" \
+ "Voice-chat with people" \
+ "${TSHOME}/icon.xpm" \
+ "TeamSpeak" \
+ "Application;Audio;Network;" \
+ false
+
+post-extract:
+ @${MKDIR} ${WRKDIR}/programs
+ @${GZIP_CMD} -dc ${DISTDIR}/setduplexfake.so.gz >${WRKDIR}/programs/setduplexfake.so
+
+post-patch:
+ @${RM} -f ${TSIMG}/TeamSpeak
+ @${MKDIR} ${WRKDIR}/doc
+.for f in Readme.txt clicense.txt manual
+ @${MV} -f ${TSIMG}/${f} ${WRKDIR}/doc
+.endfor
+.for f in TeamSpeak.bin lib*
+ @${MV} ${TSIMG}/${f} ${WRKDIR}/programs
+.endfor
+ @${MKDIR} ${WRKDIR}/programs/client_sdk
+.for f in lib* tsControl
+ @${MV} ${TSIMG}/client_sdk/${f} ${WRKDIR}/programs/client_sdk
+.endfor
+
do-install:
- ${MKDIR} ${PREFIX}/lib/teamspeak_client
- ${TAR} -C ${WRKSRC}/setup.data/image -cf ${WRKSRC}/files.tar ./
- ${TAR} -C ${PREFIX}/lib/teamspeak_client -xf ${WRKSRC}/files.tar
- ${GZIP_CMD} -dc ${DISTDIR}/setduplexfake.so.gz >${PREFIX}/lib/teamspeak_client/setduplexfake.so
- ${SED} -e 's#%%TSHOME%%#${PREFIX}/lib/teamspeak_client#' <${FILESDIR}/TeamSpeak >${WRKSRC}/TeamSpeak
- ${INSTALL_SCRIPT} ${WRKSRC}/TeamSpeak ${PREFIX}/bin/
+ cd ${TSIMG} && \
+ ${FIND} * -type d -exec ${MKDIR} "${TSHOME}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${TSHOME}/{}" \;
+ cd ${WRKDIR}/programs && \
+ ${FIND} * -type d -exec ${MKDIR} "${TSHOME}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${TSHOME}/{}" \;
+ ${INSTALL_SCRIPT} ${WRKDIR}/TeamSpeak ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ cd ${WRKDIR}/doc && \
+ ${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+.endif
.include <bsd.port.mk>