aboutsummaryrefslogtreecommitdiffstats
path: root/audio/teknap
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-06 23:53:00 +0800
committerarved <arved@FreeBSD.org>2004-08-06 23:53:00 +0800
commit1d6c32540dc8c162ed9ef92d593c949cff93d950 (patch)
treee495c5fd12b3a775e7a2bce740d0451a26dfc402 /audio/teknap
parentd802505989eff1678118db6a0a3fedea78e40296 (diff)
downloadfreebsd-ports-gnome-1d6c32540dc8c162ed9ef92d593c949cff93d950.tar.gz
freebsd-ports-gnome-1d6c32540dc8c162ed9ef92d593c949cff93d950.tar.zst
freebsd-ports-gnome-1d6c32540dc8c162ed9ef92d593c949cff93d950.zip
Fix build with gcc 3.4
Add another working mastersite.
Diffstat (limited to 'audio/teknap')
-rw-r--r--audio/teknap/Makefile2
-rw-r--r--audio/teknap/files/patch-source-scott.c10
-rw-r--r--audio/teknap/files/patch-source_term_c10
3 files changed, 21 insertions, 1 deletions
diff --git a/audio/teknap/Makefile b/audio/teknap/Makefile
index 453080b1309f..eca6150e29c7 100644
--- a/audio/teknap/Makefile
+++ b/audio/teknap/Makefile
@@ -9,7 +9,7 @@ PORTNAME= TekNap
PORTVERSION= 1.3.g
PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.sra.co.jp/pub/os/OpenBSD/distfiles/ \
+MASTER_SITES= http://got.net/~brian/teknap/ \
ftp://ftp.arnes.si/packages2/OpenBSD/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.g/g/}
diff --git a/audio/teknap/files/patch-source-scott.c b/audio/teknap/files/patch-source-scott.c
new file mode 100644
index 000000000000..a56058516c6d
--- /dev/null
+++ b/audio/teknap/files/patch-source-scott.c
@@ -0,0 +1,10 @@
+--- source/scott.c.orig Fri Aug 6 17:45:27 2004
++++ source/scott.c Fri Aug 6 17:47:15 2004
+@@ -364,6 +364,7 @@
+ mvwaddstr(main_win, 1, 0, buf);
+ }
+ #endif
++ break;
+ }
+ #if 0
+ wrefresh(main_win);
diff --git a/audio/teknap/files/patch-source_term_c b/audio/teknap/files/patch-source_term_c
new file mode 100644
index 000000000000..3909338c3503
--- /dev/null
+++ b/audio/teknap/files/patch-source_term_c
@@ -0,0 +1,10 @@
+--- source/term.c.orig Fri Jul 23 01:10:02 2004
++++ source/term.c Fri Jul 23 01:11:02 2004
+@@ -92,7 +92,6 @@
+ #endif
+
+ extern char *getenv();
+-extern char *tparm();
+
+ /*
+ * The old code assumed termcap. termcap is almost always present, but on