aboutsummaryrefslogtreecommitdiffstats
path: root/audio/toolame
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-11-25 21:06:36 +0800
committervs <vs@FreeBSD.org>2005-11-25 21:06:36 +0800
commit3f96520380c8904243a14219d8000955d1ac2817 (patch)
treecb1a2c09ae560a3839b4097a6b8313e91da990f0 /audio/toolame
parent9873640c4120f090f7502e6ee129c609799518ef (diff)
downloadfreebsd-ports-gnome-3f96520380c8904243a14219d8000955d1ac2817.tar.gz
freebsd-ports-gnome-3f96520380c8904243a14219d8000955d1ac2817.tar.zst
freebsd-ports-gnome-3f96520380c8904243a14219d8000955d1ac2817.zip
- Use PLIST_FILES/PORTDOCS
- Prune some options (overkill, can be handled by CFLAGS)
Diffstat (limited to 'audio/toolame')
-rw-r--r--audio/toolame/Makefile39
-rw-r--r--audio/toolame/pkg-plist6
2 files changed, 4 insertions, 41 deletions
diff --git a/audio/toolame/Makefile b/audio/toolame/Makefile
index d55b321d9c8e..e366b305f256 100644
--- a/audio/toolame/Makefile
+++ b/audio/toolame/Makefile
@@ -18,49 +18,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Optimized mpeg 1/2 layer 2 audio encoder
USE_GMAKE= yes
-USE_REINPLACE= yes
ALL_TARGET= ${PORTNAME}
+MAKE_ARGS= CC="${CC}" TWEAKS="${CFLAGS}" ARCH="" PG="" OPTIM=""
-DOC_FILES= FUTURE HISTORY LGPL.txt README
-
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '>>>'
- @${ECHO_MSG} '>>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
- @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
-.endif
- @${ECHO_MSG} '>>>'
-.ifndef(WITH_PROFILED)
- @${ECHO_MSG} ">>> You can enable profiling by defining WITH_PROFILED"
-.endif
+PLIST_FILES= bin/toolame
+PORTDOCS= FUTURE HISTORY LGPL.txt README
.include <bsd.port.pre.mk>
-post-patch:
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -E -e 's|\$$\(TWEAKS\)||' \
- ${WRKSRC}/Makefile
-.endif
-.ifndef(WITH_PROFILED)
- @${REINPLACE_CMD} -E -e 's|\$$\(PG\)||' \
- ${WRKSRC}/Makefile
-.endif
- @${REINPLACE_CMD} -E -e \
- 's@\$$\((ARCH|OPTIM|WARNINGS)\)@@g' \
- ${WRKSRC}/Makefile
-
-post-configure:
-# C{C,FLAGS} safeness
- @${REINPLACE_CMD} -E -e \
- 's|^(CC[[:space:]]*=).+$$|\1${CC} ${CFLAGS}|' \
- ${WRKSRC}/Makefile
-
do-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/toolame ${PREFIX}/bin
diff --git a/audio/toolame/pkg-plist b/audio/toolame/pkg-plist
deleted file mode 100644
index ae7e0cf5dce9..000000000000
--- a/audio/toolame/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/toolame
-%%PORTDOCS%%%%DOCSDIR%%/FUTURE
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY
-%%PORTDOCS%%%%DOCSDIR%%/LGPL.txt
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%