aboutsummaryrefslogtreecommitdiffstats
path: root/audio/trm
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-08 22:15:31 +0800
committerkrion <krion@FreeBSD.org>2004-02-08 22:15:31 +0800
commit1c7c1edce8bfa41f950110fc3b80bed91e85824a (patch)
tree25aad903eb3ed6f3a65a6abb570580a057d8cdc4 /audio/trm
parentba729131555edc3d4b608a057466fa50efa485d2 (diff)
downloadfreebsd-ports-gnome-1c7c1edce8bfa41f950110fc3b80bed91e85824a.tar.gz
freebsd-ports-gnome-1c7c1edce8bfa41f950110fc3b80bed91e85824a.tar.zst
freebsd-ports-gnome-1c7c1edce8bfa41f950110fc3b80bed91e85824a.zip
- Fix *_DEPENDS
PR: ports/62527 Submitted by: Ports Fury
Diffstat (limited to 'audio/trm')
-rw-r--r--audio/trm/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/audio/trm/Makefile b/audio/trm/Makefile
index 5cb891da0081..13d12e5e6713 100644
--- a/audio/trm/Makefile
+++ b/audio/trm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trm
PORTVERSION= 0.2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/ \
ftp://ftp.nl.musicbrainz.org/ \
@@ -16,17 +16,24 @@ MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= TRM generator to generate acoustic fingerprints
-BUILD_DEPENDS= madplay:${PORTSDIR}/audio/mad
-LIB_DEPENDS= musicbrainz.3:${PORTSDIR}/audio/libmusicbrainz \
+BUILD_DEPENDS= madplay:${PORTSDIR}/audio/madplay
+LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
+ musicbrainz.3:${PORTSDIR}/audio/libmusicbrainz \
vorbisfile.4:${PORTSDIR}/audio/libvorbis
-USE_GMAKE= yes
USE_REINPLACE= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
PLIST_FILES= bin/trm
post-patch:
@${REINPLACE_CMD} -e 's,-ldl,,g' ${WRKSRC}/configure
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/trm ${PREFIX}/bin
+
.include <bsd.port.mk>