aboutsummaryrefslogtreecommitdiffstats
path: root/audio/tse3
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-09-12 08:58:38 +0800
committermi <mi@FreeBSD.org>2005-09-12 08:58:38 +0800
commit7ffd91627de257bf9e67b2938f56e411e934fd4f (patch)
treeceaf6dab214bc478f58cfeb74d1b3a658ba72649 /audio/tse3
parentc14173b5b5d767dbb9fc8a173d2d499510e9efb3 (diff)
downloadfreebsd-ports-gnome-7ffd91627de257bf9e67b2938f56e411e934fd4f.tar.gz
freebsd-ports-gnome-7ffd91627de257bf9e67b2938f56e411e934fd4f.tar.zst
freebsd-ports-gnome-7ffd91627de257bf9e67b2938f56e411e934fd4f.zip
Update from 0.3.0 to 0.3.1. Unbreak on 64-bit platforms (unsigned int
vs. size_t).
Diffstat (limited to 'audio/tse3')
-rw-r--r--audio/tse3/Makefile6
-rw-r--r--audio/tse3/distinfo4
-rw-r--r--audio/tse3/files/patch-size_t27
-rw-r--r--audio/tse3/files/patch-src_tse3_Midi.h10
-rw-r--r--audio/tse3/files/patch-src_tse3_Mutex.h11
-rw-r--r--audio/tse3/files/patch-src_tse3_Notifier.h29
-rw-r--r--audio/tse3/files/patch-src_tse3_app_Application.h17
-rw-r--r--audio/tse3/files/patch-src_tse3_app_Record.h11
-rw-r--r--audio/tse3/files/patch-src_tse3_plt_Arts.cpp11
-rw-r--r--audio/tse3/files/patch-src_tse3_util_MulDiv.h12
10 files changed, 30 insertions, 108 deletions
diff --git a/audio/tse3/Makefile b/audio/tse3/Makefile
index 8059459ea319..76e7bac29c83 100644
--- a/audio/tse3/Makefile
+++ b/audio/tse3/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= tse3
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,10 +26,6 @@ MAN3= tse3.3
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsmidi:${PORTSDIR}/multimedia/kdemultimedia3
.else
diff --git a/audio/tse3/distinfo b/audio/tse3/distinfo
index f77178c986b9..74426a0518c0 100644
--- a/audio/tse3/distinfo
+++ b/audio/tse3/distinfo
@@ -1,2 +1,2 @@
-MD5 (tse3-0.3.0.tar.gz) = fbf5ebe8b96fdc9886758a42d6b1c13a
-SIZE (tse3-0.3.0.tar.gz) = 716430
+MD5 (tse3-0.3.1.tar.gz) = 3b7e35505160e2d761e5b43abb636f3c
+SIZE (tse3-0.3.1.tar.gz) = 755666
diff --git a/audio/tse3/files/patch-size_t b/audio/tse3/files/patch-size_t
new file mode 100644
index 000000000000..b3a91568cdbe
--- /dev/null
+++ b/audio/tse3/files/patch-size_t
@@ -0,0 +1,27 @@
+--- src/tse3/file/XML.h Tue Aug 23 08:37:53 2005
++++ src/tse3/file/XML.h Sun Sep 11 20:29:45 2005
+@@ -154,5 +154,5 @@
+ void element(const std::string &name, const char *value);
+ void element(const std::string &name, int value);
+- void element(const std::string &name, unsigned int value);
++ void element(const std::string &name, size_t value);
+ void element(const std::string &name, bool value);
+
+--- src/tse3/file/XML.cpp Tue Aug 23 08:32:53 2005
++++ src/tse3/file/XML.cpp Sun Sep 11 20:29:22 2005
+@@ -111,5 +111,5 @@
+
+
+-void TSE3::File::XmlFileWriter::element(const std::string &name, unsigned int value)
++void TSE3::File::XmlFileWriter::element(const std::string &name, size_t value)
+ {
+ indent(out);
+--- src/tse3/file/MidiFilter.cpp Tue Aug 23 08:32:31 2005
++++ src/tse3/file/MidiFilter.cpp Sun Sep 11 20:33:13 2005
+@@ -11,5 +11,5 @@
+
+ writer.element("Status", mf.status());
+- unsigned int c_filter = 0, p_filter = 0;
++ size_t c_filter = 0, p_filter = 0;
+ for (int n = 0; n < 16; n++) if (mf.channelFilter(n)) c_filter |= (1<<n);
+ writer.element("ChannelFilter", c_filter);
diff --git a/audio/tse3/files/patch-src_tse3_Midi.h b/audio/tse3/files/patch-src_tse3_Midi.h
deleted file mode 100644
index d789aa5061d9..000000000000
--- a/audio/tse3/files/patch-src_tse3_Midi.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/tse3/Midi.h 2004-07-13 13:42:54.171911848 -0400
-+++ src/tse3/Midi.h 2004-07-13 13:44:05.282101456 -0400
-@@ -819,6 +819,6 @@
- const MidiEvent &e1;
- };
- };
--};
-+}
-
- #endif \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_Mutex.h b/audio/tse3/files/patch-src_tse3_Mutex.h
deleted file mode 100644
index 46ce2aa5666c..000000000000
--- a/audio/tse3/files/patch-src_tse3_Mutex.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tse3/Mutex.h 2004-07-13 13:42:54.188909264 -0400
-+++ src/tse3/Mutex.h 2004-07-13 13:51:01.925761992 -0400
-@@ -315,7 +315,7 @@
- #endif
- }
- };
-- };
-+ }
- }
-
- #endif \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_Notifier.h b/audio/tse3/files/patch-src_tse3_Notifier.h
deleted file mode 100644
index 23c1be41967e..000000000000
--- a/audio/tse3/files/patch-src_tse3_Notifier.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/tse3/Notifier.h 2004-07-13 13:42:54.171911848 -0400
-+++ src/tse3/Notifier.h 2004-07-13 13:46:50.128041064 -0400
-@@ -290,7 +290,7 @@
- const p4_type &p4; // (*)
- };
-
-- };
-+ }
-
- /**************************************************************************
- * Public Notifier framework API
-@@ -367,7 +367,7 @@
- */
- typedef Listener<interface_type> listener_type;
-
-- friend class listener_type;
-+ friend class Listener<interface_type>;
-
- protected:
-
-@@ -602,7 +602,7 @@
- if (notifiers.erase(notifier)) notifier->detach(this);
- }
-
-- friend class notifier_type;
-+ friend class Notifier<interface_type>;
-
- protected:
- API \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_app_Application.h b/audio/tse3/files/patch-src_tse3_app_Application.h
deleted file mode 100644
index 606b79d91314..000000000000
--- a/audio/tse3/files/patch-src_tse3_app_Application.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/tse3/app/Application.h 2004-07-13 13:42:54.149915192 -0400
-+++ src/tse3/app/Application.h 2004-07-13 13:50:10.297610664 -0400
-@@ -35,12 +35,12 @@
- namespace Cmd
- {
- class CommandHistory;
-- };
-+ }
-
- namespace Ins
- {
- class Destination;
-- };
-+ }
-
- /**
- * The App namespace contains classes that use the @ref TSE3 \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_app_Record.h b/audio/tse3/files/patch-src_tse3_app_Record.h
deleted file mode 100644
index 4094322e803e..000000000000
--- a/audio/tse3/files/patch-src_tse3_app_Record.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tse3/app/Record.h 2004-07-13 13:42:54.152914736 -0400
-+++ src/tse3/app/Record.h 2004-07-13 13:50:33.187130928 -0400
-@@ -36,7 +36,7 @@
- namespace Cmd
- {
- class CommandHistory;
-- };
-+ }
-
- namespace App
- { classes that use the @ref TSE3 \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_plt_Arts.cpp b/audio/tse3/files/patch-src_tse3_plt_Arts.cpp
deleted file mode 100644
index 0b84298bab89..000000000000
--- a/audio/tse3/files/patch-src_tse3_plt_Arts.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tse3/plt/Arts.cpp 2004-07-13 13:42:54.158913824 -0400
-+++ src/tse3/plt/Arts.cpp 2004-07-13 13:49:02.575905928 -0400
-@@ -74,7 +74,7 @@
-
- ArtsCommon *artsCommon = 0;
- int artsCommonInit = 0;
--};
-+}
-
-
- ArtsMidiScheduler::ArtsMidiScheduler() \ No newline at end of file
diff --git a/audio/tse3/files/patch-src_tse3_util_MulDiv.h b/audio/tse3/files/patch-src_tse3_util_MulDiv.h
deleted file mode 100644
index 0191d27e2749..000000000000
--- a/audio/tse3/files/patch-src_tse3_util_MulDiv.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/tse3/util/MulDiv.h 2004-07-13 13:42:54.169912152 -0400
-+++ src/tse3/util/MulDiv.h 2004-07-13 13:48:05.942515512 -0400
-@@ -34,7 +34,7 @@
- * @return val * num / div (which coped with integer overflows)
- */
- extern int muldiv(int val, int num, int div);
-- };
-+ }
- }
-
- #endif
-) \ No newline at end of file