aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vitunes
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2010-01-06 04:27:26 +0800
committerdhn <dhn@FreeBSD.org>2010-01-06 04:27:26 +0800
commit7200505127574d8cf737004a392278791c9525eb (patch)
tree330cfa3f994b7eeb2879e927c94baeecb18f66b6 /audio/vitunes
parent423e82b285d2e0ccb81ca712074180b37bb8c5ae (diff)
downloadfreebsd-ports-gnome-7200505127574d8cf737004a392278791c9525eb.tar.gz
freebsd-ports-gnome-7200505127574d8cf737004a392278791c9525eb.tar.zst
freebsd-ports-gnome-7200505127574d8cf737004a392278791c9525eb.zip
- Update to 1.0.1
Diffstat (limited to 'audio/vitunes')
-rw-r--r--audio/vitunes/Makefile6
-rw-r--r--audio/vitunes/distinfo6
-rw-r--r--audio/vitunes/files/patch-Makefile11
-rw-r--r--audio/vitunes/files/patch-medialib.c21
-rw-r--r--audio/vitunes/files/patch-medialib.h18
-rw-r--r--audio/vitunes/files/patch-meta_info.c11
-rw-r--r--audio/vitunes/files/patch-meta_info.h10
-rw-r--r--audio/vitunes/files/patch-uinterface.h15
-rw-r--r--audio/vitunes/files/patch-vitunes.h17
-rw-r--r--audio/vitunes/pkg-descr2
10 files changed, 109 insertions, 8 deletions
diff --git a/audio/vitunes/Makefile b/audio/vitunes/Makefile
index 515eeaa11e2d..57b7360dd3a6 100644
--- a/audio/vitunes/Makefile
+++ b/audio/vitunes/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= vitunes
-PORTVERSION= 0.93
+PORTVERSION= 1.0.1
CATEGORIES= audio
-MASTER_SITES= http://www.ryanflannery.net/hacking/vitunes/files/ \
+MASTER_SITES= http://www.vitunes.org/files/ \
http://mirror.4bit.ws/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dhn
@@ -25,8 +25,6 @@ LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
MAKE_ARGS= LDFLAGS_DEPS="-L${LOCALBASE}/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile" \
CFLAGS_DEPS="-I${LOCALBASE}/include"
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
ALL_TARGET= vitunes
PLIST_FILES= bin/vitunes
diff --git a/audio/vitunes/distinfo b/audio/vitunes/distinfo
index 0be23ac36432..7ace39ed439f 100644
--- a/audio/vitunes/distinfo
+++ b/audio/vitunes/distinfo
@@ -1,3 +1,3 @@
-MD5 (vitunes-0.93.tgz) = 9eca27cd9b4991703298fd82bd677553
-SHA256 (vitunes-0.93.tgz) = a5e02a96f60806d17ae664329733a52c910a100dc9c502bbc3877bebed4d5c6b
-SIZE (vitunes-0.93.tgz) = 36201
+MD5 (vitunes-1.0.1.tgz) = 4d8250dd3623abff518e5cbc19946ee1
+SHA256 (vitunes-1.0.1.tgz) = 31d27da83a25c8084db03d3ae9917ea17cde5ba430645dd2cd898e79788ac8c8
+SIZE (vitunes-1.0.1.tgz) = 54274
diff --git a/audio/vitunes/files/patch-Makefile b/audio/vitunes/files/patch-Makefile
new file mode 100644
index 000000000000..e0b3b550ecad
--- /dev/null
+++ b/audio/vitunes/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- ./Makefile.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./Makefile 2010-01-05 18:32:48.000000000 +0100
+@@ -7,7 +7,7 @@
+ LDEPS=-L/usr/local/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile
+
+ CC=/usr/bin/gcc
+-CFLAGS=-c -Wall -ansi -g $(CDEPS)
++CFLAGS=-c -Wall -g $(CDEPS) -std=c99
+ LDFLAGS=-lutil -lncurses -lm $(LDEPS)
+
+
diff --git a/audio/vitunes/files/patch-medialib.c b/audio/vitunes/files/patch-medialib.c
new file mode 100644
index 000000000000..00cfb58826e9
--- /dev/null
+++ b/audio/vitunes/files/patch-medialib.c
@@ -0,0 +1,21 @@
+--- ./medialib.c.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./medialib.c 2010-01-05 18:32:53.000000000 +0100
+@@ -287,7 +287,8 @@
+ * last extracted meta-info from it (otherwise we ignore)
+ */
+
+- if (sb.st_mtim.tv_sec > mdb.library->files[i]->last_updated) {
++ //if (sb.st_mtim > mdb.library->files[i]->last_updated) {
++ if (sb.st_mtime > mdb.library->files[i]->last_updated) {
+ mi = meta_extract(filename);
+
+ if (mi == NULL) {
+@@ -385,7 +386,7 @@
+ if (idx != -1) {
+ /* file already exists in library database - update */
+
+- if (ftsent->fts_statp->st_mtim.tv_sec >
++ if (ftsent->fts_statp->st_mtime >
+ mdb.library->files[idx]->last_updated) {
+
+ /* file has been modified since we last extracted info */
diff --git a/audio/vitunes/files/patch-medialib.h b/audio/vitunes/files/patch-medialib.h
new file mode 100644
index 000000000000..17f4d72db14a
--- /dev/null
+++ b/audio/vitunes/files/patch-medialib.h
@@ -0,0 +1,18 @@
+--- ./medialib.h.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./medialib.h 2010-01-05 18:32:57.000000000 +0100
+@@ -7,9 +7,15 @@
+ #ifndef MEDIA_LIBRARY_H
+ #define MEDIA_LIBRARY_H
+
++#include <limits.h>
++#include <stdlib.h>
+ #include <sys/errno.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <unistd.h>
++
++typedef unsigned short u_short;
++
+ #include <fts.h>
+
+ #include "meta_info.h"
diff --git a/audio/vitunes/files/patch-meta_info.c b/audio/vitunes/files/patch-meta_info.c
new file mode 100644
index 000000000000..fe8287910aa8
--- /dev/null
+++ b/audio/vitunes/files/patch-meta_info.c
@@ -0,0 +1,11 @@
+--- ./meta_info.c.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./meta_info.c 2010-01-05 18:33:03.000000000 +0100
+@@ -678,7 +678,7 @@
+ const char *errstr = NULL;
+
+ /* note that the range is here what libid3tag can handle */
+- gindex = strtonum(mi->cinfo[MI_CINFO_GENRE], 0, 147, &errstr);
++ gindex = atoll(mi->cinfo[MI_CINFO_GENRE]);
+ if (errstr != NULL) { /* check for invalid genre number */
+ free(mi->cinfo[MI_CINFO_GENRE]);
+ mi->cinfo[MI_CINFO_GENRE] = NULL;
diff --git a/audio/vitunes/files/patch-meta_info.h b/audio/vitunes/files/patch-meta_info.h
new file mode 100644
index 000000000000..9b89a8799d70
--- /dev/null
+++ b/audio/vitunes/files/patch-meta_info.h
@@ -0,0 +1,10 @@
+--- ./meta_info.h.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./meta_info.h 2010-01-05 18:33:09.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include <limits.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <strings.h>
+ #include <ctype.h>
+ #include <time.h>
+ #include <err.h>
diff --git a/audio/vitunes/files/patch-uinterface.h b/audio/vitunes/files/patch-uinterface.h
new file mode 100644
index 000000000000..783d39fae154
--- /dev/null
+++ b/audio/vitunes/files/patch-uinterface.h
@@ -0,0 +1,15 @@
+--- ./uinterface.h.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./uinterface.h 2010-01-05 18:33:14.000000000 +0100
+@@ -17,11 +17,11 @@
+ #define UINTERFACE_H
+
+ #include <sys/ioctl.h>
+-#include <sys/ioctl_compat.h>
+ #include <ncurses.h>
+ #include <ctype.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <stdbool.h>
+ #include <termios.h>
diff --git a/audio/vitunes/files/patch-vitunes.h b/audio/vitunes/files/patch-vitunes.h
new file mode 100644
index 000000000000..b5c34c9ffddd
--- /dev/null
+++ b/audio/vitunes/files/patch-vitunes.h
@@ -0,0 +1,17 @@
+--- ./vitunes.h.orig 2010-01-04 03:17:55.000000000 +0100
++++ ./vitunes.h 2010-01-05 18:33:18.000000000 +0100
+@@ -1,10 +1,13 @@
+ #ifndef VITUNES_H
+ #define VITUNES_H
+
++#include <signal.h>
+ #include <sys/time.h>
+ #include <locale.h>
+-#include <util.h>
++//#include <util.h>
+ #include <pwd.h>
++#include <unistd.h>
++#include <getopt.h>
+
+ #include "input_handlers.h"
+ #include "uinterface.h"
diff --git a/audio/vitunes/pkg-descr b/audio/vitunes/pkg-descr
index bc44d7eb7c2f..a1facc12d969 100644
--- a/audio/vitunes/pkg-descr
+++ b/audio/vitunes/pkg-descr
@@ -3,4 +3,4 @@ systems with vim-like keybinds. It's primary goal is to serve as an index of
"tagged" multimedia files and provide a quick, easy interface for browsing &
searching your files, and creating playlists.
-WWW: http://www.ryanflannery.net/hacking/vitunes/
+WWW: http://www.vitunes.org/