aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2001-08-27 09:26:34 +0800
committertrevor <trevor@FreeBSD.org>2001-08-27 09:26:34 +0800
commit9b53abcf9538c55f306468c2bce9d6125f689be2 (patch)
treed6bfbf6ac0db0e5dfd747bbc44005ef95ece3aca /audio/vorbis-tools
parent777aa4b998be277f5ae49783d0850e50ea69379f (diff)
downloadfreebsd-ports-gnome-9b53abcf9538c55f306468c2bce9d6125f689be2.tar.gz
freebsd-ports-gnome-9b53abcf9538c55f306468c2bce9d6125f689be2.tar.zst
freebsd-ports-gnome-9b53abcf9538c55f306468c2bce9d6125f689be2.zip
Update libao to 0.8.0, which breaks mpg321. Update libogg, libvorbis,
vorbis-tools and the vorbis meta-port to 1.0rc2. This version supports "channel coupling" for more efficient compression of stereo material. Submitted by: Christian Weisgerber (maintainer)
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile19
-rw-r--r--audio/vorbis-tools/distinfo2
-rw-r--r--audio/vorbis-tools/files/patch-aclocal.m472
-rw-r--r--audio/vorbis-tools/files/patch-configure.in12
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_Makefile.am15
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_Makefile.in31
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_buffer.c55
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_ogg123.174
-rw-r--r--audio/vorbis-tools/files/patch-ogg123_ogg123.c24
-rw-r--r--audio/vorbis-tools/files/patch-ogginfo_Makefile.am10
-rw-r--r--audio/vorbis-tools/files/patch-ogginfo_Makefile.in18
-rw-r--r--audio/vorbis-tools/pkg-descr21
-rw-r--r--audio/vorbis-tools/pkg-plist3
13 files changed, 30 insertions, 326 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 6a9b0be81cbd..00d4edc8326a 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -6,30 +6,23 @@
#
PORTNAME= vorbis-tools
-PORTVERSION= 1.0.r1
+PORTVERSION= 1.0.r2
PORTEPOCH= 2
CATEGORIES= audio
-MASTER_SITES= http://www.vorbis.com/files/rc1/unix/
+MASTER_SITES= http://www.vorbis.com/files/rc2/unix/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= naddy@mips.inka.de
-LIB_DEPENDS= ao.1:${PORTSDIR}/audio/libao \
+LIB_DEPENDS= ao.2:${PORTSDIR}/audio/libao \
ogg.2:${PORTSDIR}/audio/libogg \
vorbis.0:${PORTSDIR}/audio/libvorbis
-USE_AUTOCONF= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-ao=${LOCALBASE} \
- --with-ogg=${LOCALBASE} \
- --with-vorbis=${LOCALBASE}
+CONFIGURE_ARGS= --with-ao-prefix=${LOCALBASE} \
+ --with-ogg-prefix=${LOCALBASE} \
+ --with-vorbis-prefix=${LOCALBASE}
MAN1= ogg123.1 oggenc.1 ogginfo.1
-post-extract:
- @(cd ${WRKSRC}/ogg123 ;\
- ${MV} ogg123rc-example ogg123rc ;\
- ${PERL} -pi.orig -e 's/ //' ogg123.1)
-
.include <bsd.port.mk>
diff --git a/audio/vorbis-tools/distinfo b/audio/vorbis-tools/distinfo
index f3cb45479ee0..7d0701833aa7 100644
--- a/audio/vorbis-tools/distinfo
+++ b/audio/vorbis-tools/distinfo
@@ -1 +1 @@
-MD5 (vorbis-tools-1.0rc1.tar.gz) = 40f19902e7b31571615952c29fce8389
+MD5 (vorbis-tools-1.0rc2.tar.gz) = 2c8acbc323c701bed290293cf7928554
diff --git a/audio/vorbis-tools/files/patch-aclocal.m4 b/audio/vorbis-tools/files/patch-aclocal.m4
deleted file mode 100644
index 3758df37c8c6..000000000000
--- a/audio/vorbis-tools/files/patch-aclocal.m4
+++ /dev/null
@@ -1,72 +0,0 @@
-$FreeBSD$
---- aclocal.m4.orig Mon Jun 18 06:43:11 2001
-+++ aclocal.m4 Tue Jul 17 01:38:36 2001
-@@ -313,6 +313,68 @@ int main ()
- rm -f conf.aotest
- ])
-
-+dnl Shamelessly stolen from Joerg Schilling's star.
-+dnl Copyright 1998 J. Schilling
-+
-+dnl Checks if mmap() works to get shared memory
-+dnl Defines HAVE_SMMAP on success.
-+AC_DEFUN(AC_FUNC_SMMAP,
-+[AC_CACHE_CHECK([if mmap works to get shared memory], ac_cv_func_smmap,
-+ [AC_TRY_RUN([
-+#include <sys/types.h>
-+#include <sys/mman.h>
-+
-+char *
-+mkshare()
-+{
-+ int size = 8192;
-+ int f;
-+ char *addr;
-+
-+ if ((f = open("/dev/zero", 2)) < 0)
-+ exit(1);
-+ addr = mmap(0, size, PROT_READ|PROT_WRITE, MAP_SHARED, f, 0);
-+ if (addr == (char *)-1)
-+ exit(1);
-+ close(f);
-+
-+ return (addr);
-+}
-+
-+main()
-+{
-+ char *addr;
-+
-+ addr = mkshare(8192);
-+ *addr = 'I';
-+
-+ switch (fork()) {
-+
-+ case -1:
-+ printf("help\n"); exit(1);
-+
-+ case 0: /* child */
-+ *addr = 'N';
-+ _exit(0);
-+ break;
-+ default: /* parent */
-+ wait(0);
-+ sleep(1);
-+ break;
-+ }
-+
-+ if (*addr != 'N')
-+ exit(1);
-+ exit(0);
-+}
-+],
-+ [ac_cv_func_smmap=yes],
-+ [ac_cv_func_smmap=no],
-+ [ac_cv_func_smmap=no])])
-+if test $ac_cv_func_smmap = yes; then
-+ AC_DEFINE(HAVE_SMMAP)
-+fi])
-+
- # Do all the work for Automake. This macro actually does too much --
- # some checks are only needed if your package does certain things.
- # But this isn't really a big deal.
diff --git a/audio/vorbis-tools/files/patch-configure.in b/audio/vorbis-tools/files/patch-configure.in
deleted file mode 100644
index de11cc0b7442..000000000000
--- a/audio/vorbis-tools/files/patch-configure.in
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
---- configure.in.orig Mon Feb 26 06:51:00 2001
-+++ configure.in Sun Mar 18 23:21:51 2001
-@@ -67,7 +68,7 @@ dnl ------------------------------------
- dnl Check for library functions
- dnl --------------------------------------------------
-
--dnl none
-+AC_FUNC_SMMAP
-
- dnl --------------------------------------------------
- dnl Work around FHS stupidity
diff --git a/audio/vorbis-tools/files/patch-ogg123_Makefile.am b/audio/vorbis-tools/files/patch-ogg123_Makefile.am
deleted file mode 100644
index 7b39cc2b74a8..000000000000
--- a/audio/vorbis-tools/files/patch-ogg123_Makefile.am
+++ /dev/null
@@ -1,15 +0,0 @@
-$FreeBSD$
---- ogg123/Makefile.am.orig Sun Mar 25 17:59:31 2001
-+++ ogg123/Makefile.am Tue Jul 17 03:22:47 2001
-@@ -3,9 +3,8 @@
- AUTOMAKE_OPTIONS = foreign
-
- bin_PROGRAMS = ogg123
--docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
--doc_DATA = ogg123rc-example
--mandir = $(datadir)/man
-+docdir = $(datadir)/examples/$(PACKAGE)
-+doc_DATA = ogg123rc
- man_MANS = ogg123.1
-
- INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@ @AO_CFLAGS@
diff --git a/audio/vorbis-tools/files/patch-ogg123_Makefile.in b/audio/vorbis-tools/files/patch-ogg123_Makefile.in
index 93bad3091e39..d967db0ebb44 100644
--- a/audio/vorbis-tools/files/patch-ogg123_Makefile.in
+++ b/audio/vorbis-tools/files/patch-ogg123_Makefile.in
@@ -1,23 +1,14 @@
+
$FreeBSD$
---- ogg123/Makefile.in.orig Mon Jun 18 18:18:19 2001
-+++ ogg123/Makefile.in Tue Jul 17 03:23:27 2001
-@@ -28,6 +28,7 @@ sharedstatedir = @sharedstatedir@
- localstatedir = @localstatedir@
- libdir = @libdir@
- infodir = @infodir@
-+mandir = @mandir@
- includedir = @includedir@
- oldincludedir = /usr/include
+
+--- ogg123/Makefile.in.orig Tue Aug 14 19:42:20 2001
++++ ogg123/Makefile.in Tue Aug 14 19:42:31 2001
+@@ -323,7 +323,7 @@
+ install-exec-am: install-binPROGRAMS
+ install-exec: install-exec-am
-@@ -83,9 +84,8 @@ VORBIS_LIBS = @VORBIS_LIBS@
- AUTOMAKE_OPTIONS = foreign
+-install-data-am: install-man install-docDATA
++install-data-am: install-man
+ install-data: install-data-am
- bin_PROGRAMS = ogg123
--docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
--doc_DATA = ogg123rc-example
--mandir = $(datadir)/man
-+docdir = $(datadir)/examples/$(PACKAGE)
-+doc_DATA = ogg123rc
- man_MANS = ogg123.1
-
- INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@ @AO_CFLAGS@
+ install-am: all-am
diff --git a/audio/vorbis-tools/files/patch-ogg123_buffer.c b/audio/vorbis-tools/files/patch-ogg123_buffer.c
deleted file mode 100644
index 56d0403daff2..000000000000
--- a/audio/vorbis-tools/files/patch-ogg123_buffer.c
+++ /dev/null
@@ -1,55 +0,0 @@
-$FreeBSD$
---- ogg123/buffer.c.orig Sat Jun 30 13:57:20 2001
-+++ ogg123/buffer.c Sat Jun 30 14:01:55 2001
-@@ -6,16 +6,16 @@
- */
-
- #include <sys/types.h>
-+#if HAVE_SMMAP
-+#include <sys/mman.h>
-+#else
- #include <sys/ipc.h>
- #include <sys/shm.h>
-+#endif
- #include <sys/time.h>
- #include <unistd.h> /* for fork and pipe*/
- #include <fcntl.h>
-
--#ifndef DARWIN
--#include <malloc.h>
--#endif
--
- #include "ogg123.h"
- #include "buffer.h"
-
-@@ -72,6 +72,22 @@ buf_t *fork_writer (long size, devices_t
- int childpid;
- buf_t *buf;
-
-+#if HAVE_SMMAP
-+ int fd;
-+
-+ if ((fd = open("/dev/zero", O_RDWR)) < 0)
-+ {
-+ perror ("cannot open /dev/zero");
-+ exit (1);
-+ }
-+ if ((buf = (buf_t *) mmap (0, sizeof(buf_t) + sizeof (chunk_t) * (size - 1),
-+ PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) < 0)
-+ {
-+ perror("mmap");
-+ exit(1);
-+ }
-+ close(fd);
-+#else
- /* Get the shared memory segment. */
- int shmid = shmget (IPC_PRIVATE,
- sizeof(buf_t) + sizeof (chunk_t) * (size - 1),
-@@ -94,6 +110,7 @@ buf_t *fork_writer (long size, devices_t
-
- /* Remove segment after last process detaches it or terminates. */
- shmctl(shmid, IPC_RMID, 0);
-+#endif /* HAVE_SMMAP */
-
- buffer_init (buf, size);
-
diff --git a/audio/vorbis-tools/files/patch-ogg123_ogg123.1 b/audio/vorbis-tools/files/patch-ogg123_ogg123.1
deleted file mode 100644
index 360bd101d6e5..000000000000
--- a/audio/vorbis-tools/files/patch-ogg123_ogg123.1
+++ /dev/null
@@ -1,74 +0,0 @@
-$FreeBSD$
---- ogg123/ogg123.1.orig Sat Jun 30 14:48:43 2001
-+++ ogg123/ogg123.1 Sat Jun 30 15:02:46 2001
-@@ -76,7 +76,7 @@ written to
- output overhead.
-
- .IP oss
--Open Sound System driver for Linux and {Net,Free,Open}BSD.
-+Open Sound System driver for Linux and FreeBSD.
- .RS
- Options:
- .RS
-@@ -86,6 +86,17 @@ DSP device for soundcard. Defaults to
- .RE
- .RE
-
-+.IP sun
-+Sun Audio driver for NetBSD, OpenBSD, and Solaris.
-+.RS
-+Options:
-+.RS
-+.IP dev
-+Audio device for soundcard. Defaults to
-+.B /dev/audio.
-+.RE
-+.RE
-+
- .IP alsa
- Advanced Linux Sound Architecture.
- .RS
-@@ -100,6 +111,14 @@ Override the default buffer size (in byt
- .RE
- .RE
-
-+.IP irix
-+IRIX audio driver. Note that this driver has
-+.B not
-+been tested!
-+
-+.IP arts
-+aRts Sound Daemon.
-+
- .IP esd
- Enlightened Sound Daemon.
- .RS
-@@ -111,15 +130,19 @@ after a colon, as in "whizbang.com:555".
- .RE
- .RE
-
--.IP solaris
--Solaris audio driver. Note that this driver has
--.B not
--been tested!
--
--.IP irix
--IRIX audio driver. Note that this driver has
--.B not
--been tested!
-+.IP raw
-+Raw sample output. Writes raw audio samples to a file.
-+.RS
-+Options:
-+.RS
-+.IP file
-+Sets the output file. (Default = "output.raw")
-+.RE
-+.RS
-+.IP byteorder
-+Choose big endian, little endian, or native byte order. (Default = "native")
-+.RE
-+.RE
-
- .IP wav
- WAV file output. Writes the sound data to disk in uncompressed form.
diff --git a/audio/vorbis-tools/files/patch-ogg123_ogg123.c b/audio/vorbis-tools/files/patch-ogg123_ogg123.c
deleted file mode 100644
index b67b088396b4..000000000000
--- a/audio/vorbis-tools/files/patch-ogg123_ogg123.c
+++ /dev/null
@@ -1,24 +0,0 @@
-$FreeBSD$
---- ogg123/ogg123.c.orig Mon Jun 18 18:16:50 2001
-+++ ogg123/ogg123.c Tue Jul 17 01:43:22 2001
-@@ -24,6 +24,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <netdb.h>
-+#include <sys/types.h>
- #include <netinet/in.h>
- #include <sys/socket.h>
- #include <errno.h>
-@@ -85,8 +86,10 @@ void usage(void)
- " -V, --version display Ogg123 version\n"
- " -d, --device=d uses 'd' as an output device\n"
- " Possible devices are (some may not be compiled):\n"
-- " null (output nothing), oss (for Linux and *BSD),\n"
-- " irix, solaris, wav (write to a .WAV file)\n"
-+ " null (output nothing), oss (for Linux and FreeBSD),\n"
-+ " alsa (for Linux), sun (for NetBSD, OpenBSD, Solaris),\n"
-+ " irix, arts (aRts sound daemon), esd (ESounD daemon),\n"
-+ " raw (write to a file), wav (write to a .WAV file)\n"
- " -k n, --skip n Skip the first 'n' seconds\n"
- " -o, --device-option=k:v passes special option k with value\n"
- " v to previously specified device (with -d). See\n"
diff --git a/audio/vorbis-tools/files/patch-ogginfo_Makefile.am b/audio/vorbis-tools/files/patch-ogginfo_Makefile.am
deleted file mode 100644
index 1523395fa550..000000000000
--- a/audio/vorbis-tools/files/patch-ogginfo_Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- ogginfo/Makefile.am.orig Tue Jul 17 01:23:47 2001
-+++ ogginfo/Makefile.am Tue Jul 17 01:24:00 2001
-@@ -3,7 +3,6 @@
- AUTOMAKE_OPTIONS = foreign
-
- bin_PROGRAMS = ogginfo
--mandir = $(datadir)/man
- man_MANS = ogginfo.1
-
- INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@
diff --git a/audio/vorbis-tools/files/patch-ogginfo_Makefile.in b/audio/vorbis-tools/files/patch-ogginfo_Makefile.in
deleted file mode 100644
index 0cc9192e8fef..000000000000
--- a/audio/vorbis-tools/files/patch-ogginfo_Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- ogginfo/Makefile.in.orig Tue Jul 17 01:23:50 2001
-+++ ogginfo/Makefile.in Tue Jul 17 01:24:14 2001
-@@ -28,6 +28,7 @@ sharedstatedir = @sharedstatedir@
- localstatedir = @localstatedir@
- libdir = @libdir@
- infodir = @infodir@
-+mandir = @mandir@
- includedir = @includedir@
- oldincludedir = /usr/include
-
-@@ -83,7 +84,6 @@ VORBIS_LIBS = @VORBIS_LIBS@
- AUTOMAKE_OPTIONS = foreign
-
- bin_PROGRAMS = ogginfo
--mandir = $(datadir)/man
- man_MANS = ogginfo.1
-
- INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@
diff --git a/audio/vorbis-tools/pkg-descr b/audio/vorbis-tools/pkg-descr
index 865bda108068..9c856b6f1b17 100644
--- a/audio/vorbis-tools/pkg-descr
+++ b/audio/vorbis-tools/pkg-descr
@@ -1,12 +1,13 @@
-Vorbis is a general-purpose audio and music encoding format contemporary to
-MPEG-4's AAC and TwinVQ, the next generation beyond MPEG audio layer 3. Unlike
-the MPEG sponsored formats (and other proprietary formats such as RealAudio G2
-and Windows' flavor of the month), the Vorbis CODEC specification belongs to
-the public domain. All the technical details are published and documented, and
-any software entity may make full use of the format without royalty or patent
-concerns.
+Vorbis is a general-purpose audio and music encoding format
+contemporary to MPEG-4's AAC and TwinVQ, the next generation beyond
+MPEG audio layer 3. Unlike the MPEG sponsored formats (and other
+proprietary formats such as RealAudio G2 and Windows' flavor of the
+month), the Vorbis CODEC specification belongs to the public domain.
+All the technical details are published and documented, and any
+software entity may make full use of the format without royalty or
+patent concerns.
-This package contains utilities to encode and decode vorbis streams, and to
-add comments to them.
+This package contains utilities to encode, decode, and cut vorbis
+streams, and to add comments to them.
-WWW: http://www.vorbis.com
+WWW: http://www.vorbis.com/
diff --git a/audio/vorbis-tools/pkg-plist b/audio/vorbis-tools/pkg-plist
index e98e931a0f33..213c84b5d8e0 100644
--- a/audio/vorbis-tools/pkg-plist
+++ b/audio/vorbis-tools/pkg-plist
@@ -2,6 +2,5 @@
bin/ogg123
bin/oggenc
bin/ogginfo
+bin/vcut
bin/vorbiscomment
-share/examples/vorbis-tools/ogg123rc
-@dirrm share/examples/vorbis-tools