aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vsound
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-04 06:25:17 +0800
committerpav <pav@FreeBSD.org>2005-10-04 06:25:17 +0800
commit23bbd8ccd7f79f2af691d56ac1dcbbae8419d390 (patch)
tree275b17d751bd0492e2cfdda941c221c38f0d8a44 /audio/vsound
parente784280d38fa7bae88ee4b6d62f8302004e849bf (diff)
downloadfreebsd-ports-gnome-23bbd8ccd7f79f2af691d56ac1dcbbae8419d390.tar.gz
freebsd-ports-gnome-23bbd8ccd7f79f2af691d56ac1dcbbae8419d390.tar.zst
freebsd-ports-gnome-23bbd8ccd7f79f2af691d56ac1dcbbae8419d390.zip
- Fix runtime crash [1]
- Update WWW - Style PR: ports/86365 [1] Submitted by: Fred Wheeler <fred.s.wheeler@gmail.com>
Diffstat (limited to 'audio/vsound')
-rw-r--r--audio/vsound/Makefile11
-rw-r--r--audio/vsound/files/patch-vsound.c15
-rw-r--r--audio/vsound/pkg-descr3
3 files changed, 18 insertions, 11 deletions
diff --git a/audio/vsound/Makefile b/audio/vsound/Makefile
index 410c8c8c72fd..38c7a436fcfd 100644
--- a/audio/vsound/Makefile
+++ b/audio/vsound/Makefile
@@ -1,12 +1,13 @@
-# New ports collection makefile for: linux-vsound
-# Date created: 13 June 2002
-# Whom: Rahul Siddharthan <rsidd@online.fr>
+# New ports collection makefile for: linux-vsound
+# Date created: 13 June 2002
+# Whom: Rahul Siddharthan <rsidd@online.fr>
#
# $FreeBSD$
#
PORTNAME= vsound
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.zorg.org/vsound/
@@ -18,12 +19,10 @@ RUN_DEPENDS= sox:${PORTSDIR}/audio/sox
USE_LIBTOOL_VER=15
-.include <bsd.port.pre.mk>
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/vsound/files/patch-vsound.c b/audio/vsound/files/patch-vsound.c
index 65aed69135b3..317fc6fdda2b 100644
--- a/audio/vsound/files/patch-vsound.c
+++ b/audio/vsound/files/patch-vsound.c
@@ -1,6 +1,6 @@
---- vsound.c.orig Tue Apr 13 16:52:15 2004
-+++ vsound.c Tue Apr 13 17:01:30 2004
-@@ -70,11 +70,11 @@
+--- vsound.c.orig Sat Jul 10 23:29:33 2004
++++ vsound.c Tue Oct 4 00:20:25 2005
+@@ -73,11 +73,11 @@
/*------------------------------------------------------------------------------
** Macros to handle big/little endian issues.
*/
@@ -14,3 +14,12 @@
#if (__BYTE_ORDER == __LITTLE_ENDIAN)
#define CPU_IS_LITTLE_ENDIAN 1
#define CPU_IS_BIG_ENDIAN 0
+@@ -210,7 +210,7 @@
+ dsp_init () ;
+
+ va_start (args, flags) ;
+- mode = va_arg (args, mode_t) ;
++ mode = va_arg (args, int) ;
+ va_end (args) ;
+
+ if (strcmp (pathname, "/dev/dsp"))
diff --git a/audio/vsound/pkg-descr b/audio/vsound/pkg-descr
index a896c73f69ff..b4fbcb64ddcd 100644
--- a/audio/vsound/pkg-descr
+++ b/audio/vsound/pkg-descr
@@ -14,5 +14,4 @@ if you connected a loopback cable to the line in and line out jacks on
your sound card, but no DA or AD conversions take place, so quality is
not lost.
-Erik de Castro Lopo <erikd@zip.com.au>
-WWW: http://www.zip.com.au/~erikd/vsound/
+WWW: http://www.zorg.org/vsound/